Download

Audio related crash

I posted this in the Answerhub but wasn’t sure which section was correct for the issue. My game is crashing with the message below. I’m using ‘set base mix’ in blueprints to change volume levels. Before I unload a map I bring the volume down in that map and bring up a background sound that’s constantly looping in the persistent level, and then when the new map loads in I do the reverse.

The crash always occurs on level changes but it’s not consistent - sometimes I can get through a number of levels before it happens, sometimes not.This happens both when playing in editor and in a packaged project (with the same error message).

I’m not sure how to go about solving this, any ideas would be great!

Assertion failed: SoundWave && SoundWave->bProcedural [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/AudioMixer/Private/AudioMixerSourceBuffer.cpp] [Line: 507]

UE4Editor_Core
UE4Editor_Core
UE4Editor_AudioMixer
UE4Editor_AudioMixer
UE4Editor_AudioMixer
UE4Editor_AudioMixer
UE4Editor_AudioMixer
UE4Editor_AudioMixer
UE4Editor_AudioMixerCore
UE4Editor_AudioMixerCore
UE4Editor_AudioMixerCore
UE4Editor_Core
UE4Editor_Core
kernel32
ntdll

For anyone that might come across this via search - I set the project to stream all sound waves longer than 5 seconds and it seems to have solved the problem.

Edit - not solved - the crash came back after not showing up for a while ;_;
Because the crash is so intermittent it’s really tough to fix.

Further edit! - Switched to the old audio engine after trying everything else and that fixed it.

Got the same problem here. Stacktrace from 4.24.2:



Assertion failed: SoundWave && SoundWave->bProcedural [File:D:/Build/++UE4/Sync/Engine/Source/Runtime/AudioMixer/Private/AudioMixerSourceBuffer.cpp] [Line: 507]

UE4Editor_Core!AssertFailedImplV() [d:\build\++ue4\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:105]
UE4Editor_Core!FDebug::CheckVerifyFailedImpl() [d:\build\++ue4\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:455]
UE4Editor_AudioMixer!Audio::FMixerSourceBuffer::OnEndGenerate() [d:\build\++ue4\sync\engine\source\runtime\audiomixer\private\audiomixersourcebuffer.cpp:507]
UE4Editor_AudioMixer!Audio::FMixerSourceBuffer::`scalar deleting destructor'()
UE4Editor_AudioMixer!TArray<TSharedPtr<Audio::FMixerSourceBuffer,0>,TSizedDefaultAllocator<32> >::RemoveAtSwapImpl() [d:\build\++ue4\sync\engine\source\runtime\core\public\containers\array.h:1565]
UE4Editor_AudioMixer!Audio::FMixerSourceManager::UpdatePendingReleaseData() [d:\build\++ue4\sync\engine\source\runtime\audiomixer\private\audiomixersourcemanager.cpp:2613]
UE4Editor_AudioMixer!Audio::FMixerSourceManager::ComputeNextBlockOfSamples() [d:\build\++ue4\sync\engine\source\runtime\audiomixer\private\audiomixersourcemanager.cpp:2463]
UE4Editor_AudioMixer!Audio::FMixerDevice::OnProcessAudioStream() [d:\build\++ue4\sync\engine\source\runtime\audiomixer\private\audiomixerdevice.cpp:534]
UE4Editor_AudioMixerCore!Audio::FOutputBuffer::MixNextBuffer() [d:\build\++ue4\sync\engine\source\runtime\audiomixercore\private\audiomixer.cpp:186]
UE4Editor_AudioMixerCore!Audio::IAudioMixerPlatformInterface::RunInternal() [d:\build\++ue4\sync\engine\source\runtime\audiomixercore\private\audiomixer.cpp:685]
UE4Editor_AudioMixerCore!Audio::IAudioMixerPlatformInterface::Run() [d:\build\++ue4\sync\engine\source\runtime\audiomixercore\private\audiomixer.cpp:720]
UE4Editor_Core!FRunnableThreadWin::Run() [d:\build\++ue4\sync\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:96]


Is it really a bug with the new audio mixer or are there any changes required to the project code / settings?

I couldn’t find a solution anywhere as well, but then I checked the source for the engine and saw it was fixed on the 4.25 branch already. You might need to apply this commit to your version of the engine manually https://github.com/EpicGames/UnrealEngine/commit/493e4c54091da273741e23638c650aa82d5ccdce

Hey hey, I have the exact same issue, but the link is dead, do you know where I can find this commit ? Thanks!

The link works, but our account gotta link your Epic/Unreal account with Github!

Google says:

To connect your Github and Unreal Engine/Epic Games accounts:

  1. Navigate to your Connected Accounts page.
  2. Click CONNECT under GITHUB.
  3. Log in to your GITHUB account on the new window that opens.
  4. Click Sign In.
  5. You will receive a confirmation email from Github with a verification link.

Not sure if this error needs the patch, even though I applied the patch, only restarting the computer resolved it for me, or perhaps both actions are needed.

where is this patch?

This bug has been resolved for 4.25, the GitHub link above was the link to the relevant change. As Arthur said, you need to log in to GitHub properly.

does someone have the file i cant find it to download