Audio not working after loading level

To provide some context for this issue, I have a main menu and several levels which I can load from this menu.
My game also has background music, voice and sound effects. Their volumes can be changed in an options menu.
This is a purely blueprint-based project and no C++ is used. I am currently using the latest version, UE 4.14.

When loading a level from the main menu (both PIE and packaged game) and then immediately quitting back to the main menu after it has loaded, the music (which plays in the menu background) no longer works. When going back into a level again, I find that the music (and some of the voices / sound effects) no longer work in the level either.

I use sound mix modifiers to change the global audio volumes of the music/voice/effects sounds, and these are applied every time a level is loaded (including the main menu). Here is what I have investigated/tried:

  • I have checked the logs, and after a thorough search for everything related to audio and sound, I have found no errors or warnings, or indeed anything relating to global audio settings other than recognising my hardware.
  • I have used print statements to check the volume multiplier of the sound components producing the music and this remains at 1.0 (as it should).
  • I have used print statements to check what float is being fed into the ‘volume’ input for the ‘set sound mix class override’ node (which is followed by ‘push sound mix modifier’) and this shows the correct float value (i.e. not 0.0).
  • I have used ‘clear sound mix modifiers’ and ‘clear sound mix class override’ (the latter affecting the music class). This does not fix the issue.
  • I have forced the audio to start playing after a delay of 0.5 seconds after level load. This does nothing, but a print statement displays ‘true’ when reading the value of ‘IsPlaying’ from the audio component (i.e. it is playing but no sound is produced). Also activating the component does not fix the issue as it appears to be activated already.
  • I have tried recording audio directly from the stereo mix device through the audacity software to see if it was my headset, and it too recorded no audio when my headset played no audio.
  • I have tried changing when sound mix modifiers are pushed, such that only the main menu level triggers the modifiers on ‘event begin play’ (i.e. the modifiers are not pushed as soon as a level other than the main menu is loaded).

Exiting the PIE mode and restarting in PIE resets everything, meaning the audio works again, however the same process happens when repeating the steps outlined on the 2nd paragraph. Exiting my packaged game and restarting also fixes everything, however the same applies.

Does anyone know what could be causing this, or indeed if it is a bug?

Thanks for your time,


Are you pausing/unpausing?

Have you tried the patch I described in this thread:

The game is paused every time I bring up the in-game menu to exit back to the main menu, so this is probably the issue. I will have to download the source engine, but I think it’s safe to say that this is the issue as it matches my problem pretty well.



I just downloaded the source and added the patch, but this did not work.

There is a temporary work around for this, which is to set all of the sound classes ‘bIsUISound’ to true. This means that the sounds are not actually paused when SetGamePaused is used, so the issue is avoided. It does mean that there are some sounds (like explosions or what not) which continue to play during the pause menu, but this is not really much of an issue in terms of game play for me.

Hopefully this is fixed for 4.14.2!

Hey Xarastoph,

This is a known and reported issue, and has since been entered as a bug and fixed internally. I verified this fix is working as expected within the 4.14.2 release so you will need to wait until that has rolled out to get the official fix.


Let me know if you have additional questions.

Thank you,

I have the same Problem. But now i run 4.14.3 and the Sound stops playing after Level load. Will there be another fix?

This fix actually didn’t make it into the 4.14.3 hotfix due to an error with the verification process.

We are working to get this into an upcoming hotfix or full engine release. Thank you for your patience while we get this resolved.