Audio is randomly distorted

So I’m getting a random issue with calling Sounds or Sound Cues from within my Character Blueprint with a Play Sound at Location or the Play Audio Component node.

Basically the sound will sometimes play okay, and other times it will come through horribly distorted, but it’s really random which it’s going to do. And other instances, the audio as a whole starts off fine but randomly distorts in the process of playing it, sometimes to the point that the entire audio file is actually taking longer to play.

In either instance, the sound is so horribly garbled by whatever mystery lag is effecting it, that it’s just not usable, even though graphically everything still seems to be running fine. I’ve tried adjusting the volume multiplier, attenuation, and a few other random settings, and it doesn’t seem to help with the issue at all. It’s not like most of them are really big or long sounds either, they’re mostly basic melee sound effects for swinging at or hitting an enemy, so they’re not too elaborate, although they are sometimes played in rapid succession or simultaneously by either the Player or AI characters…

Anyone else getting this, or have some suggestions on how to find and fix the cause of this?

Same here :\


Sounds like if multiple instances of the sound are played in the same time…
Look at your sound cue (you do work with sound cue, don’t you ?) and lower “Max concurrent Play Count” (try 1 to see if the issue comes from here),



Thank you so much, it fixed my issue.

Forgot to respond, but I tried this, and it made no difference, I was still getting the issue.

My best guess at this point is it’s a performance issue with my laptop, since it only has a dual core processor, and hardly the greatest of system specs in general, so it’s probably just audio lag…

For me, certain sound effects like the ones from the starter content, cause major distortion and slow-down. This also happens for me for sounds that are not 44.1k sample rates. When I convert my 48k files to 44.1, and remove all starter content sounds, my issues go away. Very strange. Any feedback as to what exactly is happening would be most appreciated, as this has been very difficult to work around or understand.