Audio in editor/ingame has never worked on any version of UE4

Just a shot in the dark here… have you tried disabling your Samsung Display in the playback devices list?

It’d be helpful if you load the editor, try playing a sound cue, then close the editor, and then upload the log file. Logs can be found in ProjectName\Saved\Logs. The most recent log is usually ProjectName.log

From the very beginning when i first got UE4, at version 4.0.2 up until now at 4.7.1, sound in the editor/ingame has never worked. My speakers are 5.1 surround sound, editor sounds are enabled, UE4 does not show up in my volume mixer and the WindowsEngine.ini in UE4\Engine\Config\Windows\ is there. I have gone through all troubleshooting steps for similar problems but have not been able to get audio to work.

Here are my specs from dxdiag

If there is any additional troubleshooting steps you would like for me to take, or any additional information you need, please tell me.

I tried disabling my monitor’s sound, but it had no effect.
I read through my logs and may have found the problem, but I do not know how to fix it.

[2015.03.08-01.56.54:523][0]LogModuleManager:Warning: ModuleManager: Unable to load module ‘C:/Program Files/Unreal Engine/4.7/Engine/Binaries/Win64/UE4Editor-XAudio2.dll’ because the file couldn’t be loaded by the OS.

Try downloading, and installing this: Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center

It seems that you’re missing your xaudio2 files, and it comes with that :slight_smile:

I reinstalled DirectX 11 Jun 10 redistributable and restarted my computer but the problem still persists.

Hey ImRealNow,

This does not seem to be the Editor if you have been prompted with the message:

[2015.03.08-01.56.54:523][0]LogModuleManager:Warning: ModuleManager: Unable to load module ‘C:/Program Files/Unreal Engine/4.7/Engine/Binaries/Win64/UE4Editor-XAudio2.dll’ because the file couldn’t be loaded by the OS.

After you have installed the Directx11 SDK and updated your audio driver, I would also re-install the Engine. This will make sure that your audio .dll files are correct and associated with your Engine versions. I know this is not the preferred solution, but it will ensure the issue is not with you computer, but something with the audio in the Engine.

Thank you,

Andrew Hurley

I had already reinstalled the engine through the installer to no effect. I have also confirmed that all xaudio2 DLLs are in both system32 and SysWOW64 folders in my windows directory. I’m starting to think that the only step that I can take to fix it is to reinstall windows, but I would like to avoid that hassle if possible.

Hello ImRealNow,

Before you try re-installing Windows completely, we should explore a couple more options. I usually do not suggest a full Windows re-install until it is the last resort.

I noticed you have a ‘Realtek High Definition Audio’ device set as your default playback device. Open your ‘Realtek HD Audio Manager’ and try changing the ‘Speaker Configuration’ to ‘Stereo’ and your Default Format to 24 bits 48,000 Hz, Studio Qualtiy. Also try checking the ‘Virtual Surround’ option if available.

RealTek HD Audio Manager

The red boxes surround the options I mentioned.

Default Format

33301-default+format.png

Advanced Settings

33302-advancedsettings.png

Hopefully your driver application looks similar, but use this image as a reference to where these options can be found and changed on your own computer.

Let me know if any of this helped resolve your issue, or if you need some more help.

Regards,

Andrew Hurley

unfortunately, changing my audio driver settings has no effect on getting he audio to run in UE4.

My final suggestion would be to check your ‘Editor Preferences’ within the ‘Miscellaneous’ section for, "Enable Editor Sounds.’

Hopefully this is the fix, but if not your next option would be to re-install the Engine completely. Meaning, create a copy of your Unreal Projects folder, and then delete not only the Engine from your Program files, but also the Launcher.

Regards,

Andrew Hurley

A complete re-install did not fix the issue. The only thing left for me to do is is re-install windows, i think.

Have you tried rolling back your Audio Driver to its original state?

rolling back the audio driver still couldn’t get the sound to work. i also tried giving my account full control permission over all xaudio2 dlls, but that didn’t work either.

Hey ImRealNow,

By this point my final suggestion would be to re-install the editor completely. This means not only through the launcher, but also the launcher itself. Remove any associated files with the engine, of course making copies of projects and content you wish to keep.

If this does not work, then your last suggestion to re-install Windows might be the next step. Please let me know what you decide to do, and what ends up working for you, if anything.

Cheers,

Andrew Hurley