Audio from trigger? 4.15 problem?

I may have put this in the wrong forum section originally, I didn’t know we had an audio forum!!

I’ve used the same setup with no issues in 4.12.5 but 4.15 doesnt seem to work, any ideas guys?!

Hey Delta1, just now going through the post-

For starters, if you don’t want an Audio Component to automatically start on Begin Play, uncheck the “Auto Activate” box in the details pane. This will prevent you from having to do that Volume Multiplier hack.

If you set up a breakpoint on the Trigger Volume overlap events (highlight node, hit F9), are you hitting them? This isn’t technically audio related, but instead involves Collision Filters and ensuring Generate Overlap Events is enabled for the things you need it for.


To ensure that only the player can trip the Trigger Volume, you’ll need to pipe in the “Overlapped Actor” param from the event, like so:


The way you’re currently doing it with Get Player Character will always be true because you’re grabbing the player object, not the object coming from the overlap. I would also advise doing the same check for the End Overlap event.

Thanks for that Seth, much appreciated!