Download

Attenuation on Moving Sound Source

In a level I’m building, I’ve created an AI NPC that is just walking around mindlessly. He’s supposed to be a robot, and I want him to emit a light mechanical hum as he walks around. I created a sound notify in his walking animation that cues the humming audio file upon taking his first step, but I can’t seem to find any way to get the audio to attenuate relative to the AI’s location. I’ve set the file to “follow” and appended it to one of his feet, but once the notify is cued, the audio is ubiquitous, the same volume no matter where the AI or the player character are on the map. Any suggestions? (I’m brand new to all of this, so please go easy on me, haha).

Did you assign an attenuation to the audio asset, or set override attenuation? Also is the sound a part of the NPCs blueprint, or are you playing sound at a set location? What you’ll want to do is set your attenuation settings in the sound cue, then place a copy of it in your NPC’s blueprint. Use the anim notify to activate the sound and it should follow him around, and attenuate. Let me know if you have any further questions and I’ll be happy to assist. =)

@SE_JonF

Aha! That caught part of the problem. I hadn’t created a cue; the anim notify was directly triggering the WAV file, which obviously doesn’t allow for attenuation tweaking, haha. I’ve now got the cue created, but I’m unsure how to get it into the NPC’s blueprint. Do I just drag and drop it into the component menu, or do I need to create some kind of player node in the event graph? (thanks for your help thus far, btw!)

Glad to hear!

So what you want to do is select the cue in your content browser, then in your NPC blueprint click Add Component, and it should have the name of your sound cue next to the audio asset under common. =) After that, you can either leave it at auto activate in which case it will activate that sound whenever the NPC blueprint is created, or you can trigger it during specific times using the anim notify. If you do the latter make sure you untick auto activate in the properties of the audio component once you’ve added it to your blueprint.

@SE_JonF

Awesome! Sounds straight-forward enough. I’ll give that a try and let you know if I have any more questions:) You’re the best

Happy to help. Good luck! =)