Attenuation max radius

I think i’m definitely damned with attenuations.

Here is my question : is there a max radius where the sound is not played anymore when setting up an attenuation ?

If i setup an attenuation with a radius of 5000 and a falloff distance of 1000, i get a sound nicely fading in. Just what i want.
If i setup an attenuation with a radius of 6000 and a falloff distance of 1000, i get a sound starting immediatly with no fade.

In the picture underneath, my player start (red spot) is around 6500 (attenuation units ?!?) away from the audio source, the radius is set to 10 000. I should hear the sound loud and clear when i launch the map. I don’t.
I only hear the sound when i get around 6000 units from the source.

Like the previous thread on the log reverse, am I missing something ?
I did search on google and on the answerhub, i don’t find any infos on a potential maximum radius or something like that.

Hey Olivier,

What do you have the sound type set to?

Would you mind taking a screenshot of the settings for this particular sound placed in your scene?


Andrew Hurley

My guess would be to increase the compression quality to see if that has any effect?

No problem at all ! ( I blurred the file names just in case, even if it’s not too hard to find which project i’m working on ).

So here is the node for the sound cue, the settings of the sound cue, the settings of the attenuation and the settings of the wav file.

Ok, i’ll try that, i get back to you asap. Thanks :slight_smile:

No problem, thank you for your patience.

No problem, i understand that the engine is still in dev and that these kind of things can happen.

So… I didn’t even had to change the compression. When i launched the project today, the sound was working with a radius of 10000.

I joined a screenshot of what i was working on before the problem appeared.

I was trying to use the node Crossfade by distance, i changed a lot of parameters including “attenuate with LPF” in the attenuation to test it out.

My guess is that the audio system kinda bugged while i was working, and was unable to render the sound above 6000.

The value of 6000 was the value i used the first time when i setup the Crossfade node.

Now it’s working with and without the crossfade node, and above 6000 or 10000. And i’m really honest, i haven’t change anything at first, i just opened the project and the map and tried to see if the issue was still there before trying to change the compression.

I don’t have anything suspicious in the logs, so i can’t really explain why this happened. :confused:

The Audio is still in development as you said, so these kind of things can happen with un-reproducible results. As long as it is working as intended now that is all that matters. If this happens again though, and you are unable to get it to work at all, even after re-loading your project, contact us because it could be more major than just a small functioning error.

Either way good luck, and we appreciate your patience and information regarding this issue! :slight_smile:

Allright, thank you for your patience too.

I’ll update the question if i have something similar happening.

And I’ll keep posting threads / questions if I have any other issues. Making the engine better is also part of us (devs, sounddesigners, 3d artists etc…) sharing bugs and problems if we got some imho.