Attempting to move fully simulated skeletal mesh error

This error keeps spamming my message log.

I’ve narrowed down the source of the problem to something within the ragdolling.
Basically when the player dies he ragdolls, but after that movement is no longer updated even after un-ragdoll.

This is using the Advanced Locomotion System off the marketplace. I’ve tweaked and added quite a few things, but nothing that should’ve affected ragdolling.
I should also mention this only became a recent problem and was previously working perfectly fine.

I re-targeted the system to a new character succesfully but apparantly something is still missing or was changed?

This question should probably also go in that thread too but forums are down right now.

1 Like

Hey, i have the exact same problem, did you yet find a solution ?

1 Like

Exact same problem too

I already solved the problem. It’s because the translations of the pelvis in the physical asset needs to be set to be unlocked. Check the physical asset of the locomotion systems character and you will see what I mean.

I don’t get it, can you explain yourself please?

In the physics asset tool you must add a rigidbody to the root bone and set it to kinematic. Then, go to the constraints in the pelvis and unlock its translations. That should do it.

1 Like

In the physics asset tool you must add a rigidbody to the root bone and set it to kinematic. Then, go to the constraints in the pelvis and unlock its translations. That should do it.

Thanks! Resolved

I can say a few months later that this still works just fine! Solved my problem!

WHere do you add the rigidbody?

Inside the Physics Asset editor (as of Unreal Engine 4.18), right click any bone and you’ll be able to add/replace bodies.

I think I fixed it by going to the physics asset for the mannequin, finding spine_01, and under that the spine_01: pelvis constraint. Then, in the Details panel on the right, in the Linear Limits section, change all three axes from Locked to Limited, and set the limit to 10. (I tried Free first, but then shooting the character broke it in half.) I need lots more testing before knowing if this stops that warning message.

How add rigidbody in skeleton menu and unlock translation

Where to unlock translation?

Ok. As i see many people dosen’t underestand so here i go.
Open physics asset of your mannequin or other rig and you will see this:


I already did it so y have root body, but you dont.
To add it go here into this thing and select->Show All Bones

It’s Ue5 btw, but in ue4 it looks similar. After clicking there it will look like this:
image
Next - click to the … hm to the root bone right mouse button->Add Sphere

It will appear in the root of character here:
image
Ok, now we need to select this body and set it’s Physics Type to kinematic at the right panel:
image
Why do we need this body anyway? Well… if you have to make ragdoll, then you, probably, attaching your character to something(capsule?) during ragdoll state. But since there is No kinematic bodies by default - engine will throw you error. Each attachable rig should have kinematic body on it.
But we are not done yet.
In the bottom left screen you can see body constraints tab, here:

I already set it so in your case it will have only one body ant it’s the root itself.
We need to attach Pelvis to the Root. Click at the root … item with right mouse->Constraints-> select Pelvis bone

After douing so during ragdoll your character will look like this:
image
Why? Because our pelvis locked by root.
We need to free it. So go to created Root body and click on the constraint Root->Pelvis in there:

In Right details tab you can find this:

Linear Limits. They are locked by default but you can set them to Free! Do so.
image
And here we go. All works, no warnings.
Don’t worry about root body collision with the ground. Just note Not to set “Ragdoll” type of physics to the Whole character mesh. Enable ragdoll this way instead:
image
In this case kinematically simulated root bone won’t affect world transforms. Also you can set in the constraints some limits yourself if need so. Ok, hope my post helps someone.

16 Likes

Wow, and after 5 years this solution still stands, thank you so much @AlexanderSt for taking the time to depict this step by step.

Bump** ; )

2 Likes

Anyone happen to have any idea where to look if that above solution doesn’t work? I’ve tried fiddling with the constraints and root a bunch but nothing seems to solve the issue. It’s setup exactly as described in AlexanderSt’s post. If I set it to set simulated starting from “spine_01” it works fine without warnings but the character then of course only ragdolls from the waist up. Any help would be awesome, thanks!

Darn I found a situation where this solution doesn’t work. I have a weapon that is simulating physics when in the environment (not picked up) and I get this error when I pick up the weapon, and it doesn’t attach to the character (AttachToComponent) when I implement this solution, the warning stops, but it still doesn’t attach to the character and instead falls through the world, and keeps going.

usually you attach weapon not to collision, but to the bone and AttachToComponent works with bones. If you replace weapon with static mesh - attach will work? If so - make sure that your weapon’s rig has root bone simulation marked as Kinematic. Select root collision body of your weapon’s physics asset, in right sidebar you will see … dropdown named as - Physics Type, set it as kinematic there.

It is attaching to a bone (socket) Ive tried setting it to kinimatic but then its the same as it not simulating physics at all, and just site in the air when the level starts.