" Attempt to construct staged filesystem reference from absolute path" Solution?


I’m trying to build my first VR app and it’s targeting the Oculus Go. I’ve been able to deploy once before and then when I added more mesh to the project to finish the model, I imported my windows with Datasmith called “Windows” and when I removed the Unreal Studio plugins from the project, as you can’t build for mobile or deploy to mobile with any enabled, I then got an error saying I couldn’t use assets called “Windows” as it was interfering with things like ‘win64’ etc. So to then try and fix this, I removed that asset totally and then I got another error which seems to be unfixable. I get this message in the log:

l: Error: ERROR: System.ArgumentException: Attempt to construct staged filesystem reference from absolute path (/Content/Levels/OfficeSpace_BuiltData.uexp). Staged paths are always relative to the staging root.
LogPlayLevel: at StagedFileSystemReference…ctor(String InName) in D:\Build++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\StagedFileSystemReference.cs:line 44
LogPlayLevel: at StagedFileReference…ctor(String Name) in D:\Build++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\StagedFileReference.cs:line 20
LogPlayLevel: at Project.ReadDeployedManifest(ProjectParams Params, DeploymentContext SC, List1 ManifestList) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:line 2512 LogPlayLevel: at Project.CopyBuildToStagingDirectory(ProjectParams Params) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs:line 2825 LogPlayLevel: at BuildCookRun.DoBuildCookRun(ProjectParams Params) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Scripts\BuildCookRun.Automation.cs:line 219 LogPlayLevel: at BuildCookRun.ExecuteBuild() in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Scripts\BuildCookRun.Automation.cs:line 41 LogPlayLevel: at AutomationTool.BuildCommand.Execute() in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\BuildCommand.cs:line 242 LogPlayLevel: at AutomationTool.Automation.Execute(List1 CommandsToExecute, Dictionary2 Commands) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\Automation.cs:line 563 LogPlayLevel: at AutomationTool.Automation.Process(String[] Arguments, StartupTraceListener StartupListener) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\Automation.cs:line 533 LogPlayLevel: at AutomationTool.Program.MainProc(String[] Arguments, StartupTraceListener StartupListener) in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Program.cs:line 173 LogPlayLevel: at AutomationTool.Program.<>c__DisplayClass1_0.b__2() in D:\Build\++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Program.cs:line 99 LogPlayLevel: at AutomationTool.InternalUtils.RunSingleInstance(Func1 Main) in D:\Build++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\AutomationUtils\Utils.cs:line 725
LogPlayLevel: at AutomationTool.Program.Main() in D:\Build++UE4\Sync\Engine\Saved\CsTools\Engine\Source\Programs\AutomationTool\Program.cs:line 99
LogPlayLevel: (see C:\Users\jxb.GSS\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.21\Log.txt for full exception trace)
LogPlayLevel: AutomationTool exiting with ExitCode=1 (Error_Unknown)
LogPlayLevel: Completed Launch On Stage: Deploy Task, Time: 109.101705
PackagingResults: Error: Launch failed! Unknown Error

I’ve looked all over and not found anything to fix it. I’ve tried deleting the Build Data file in Unreal and then checking the content folder to see if the .uexp is there and it wasn’t so tried again and got the same error again.

I then also tried to rename the level and create a new build data and it still didn’t work.

I also moved the project to another file and then, for some reason, that project crashed and wouldn’t run again so I’m presuming it’s something to do with Unreal Studio that broke that.

Is there any explanation behind this error or a solution? I’m not a programmer so I don’t know what much of this means but I’ve not found anything on it.

Thanks for any help.

1 Like

Hi I was getting the same error for my application too. It’s caused by a broken manifest file from a failed build that is not cleaned up in the UE4Game folder on the Go.

The way I solved it was this:

(In CMD)

  • adb shell

  • cd sdcard

  • ls (you should see the UE4Game directory listed)

  • rm -r UE4Game

Then rebuild and launch your project and it should work!


Hello, i’m having the same problem. I don’t understand what and where the CMD is, could you help me with a little video or some pictures?

Hey, CMD is Command prompt and you can access it by typing CMD in to your windows search bar. From there just type in the highlighted lines in the second image.

Hey, thank you for the tip. It works for me. I appreciate the answer.

Thanks a bunch. Worked for me as well!

Works fine!

Thank you very much, I had the same issue, but it work out!

Works fine for me while i’m deploy my AR project to my android phone! Thanks a lot.

Thanks a lot. You can also manually delete the folder from the phone itself.

Just to second the manual approach if anyone is struggling with the cmd prompt.

The cmd prompt didn’t work for me, but I went into my phone files, searched for the UE4 folder, found the app and deleted the files (including the trash). I also deleted the app from my home screen. With all the done my AR app built no problem.


Was having issues with launching to my Quest 2 and this solved it :slight_smile:

Confirmed worked! Thanks!

worked for me as well and saved A LOT of reconstruction time. thanx a lot

thank you…

Thanks a lot man, safe my day

IF like me you do not see the $ mark after inputting rm -r UE4Game/ even after waiting a long time, try exiting any open UE4 projects first and the run the command.

Thank you, Sir, You are a scholar and a gentleman!

It worked for me !
Thanks saved my Day

Worked for me, too. Thanks! :slightly_smiling_face:
The problem appeared from nowhere. I was launching ok (to Meta Quest2), and 10 minutes later, I coudn’t launch.
Also, if I chose to package the project and upload it to the Quest, I did not get an error, but the app oppened full black in an infinite waiting loop.
But deleting the directory as explained above worked.
Someone even made a video on Youtube, referencing to this page and showing the process.

Also there is this forum post reaching to the same conclusion
ERROR: System.ArgumentException: Attempt to construct staged filesystem reference from absolute path - #7 by rasamaya>