Attempt to build nav mesh for actor crashes on start

Using 4.11.2, building in distribution mode for Android SDK 14 and up, running on 6.0.1 on a OnePlus One (with Adreno 330)

On startup, I get the following error, and the application exits:

05-23 21:03:50.282 23429 23444 D UE4     : [2016.05.24-04.03.50:282]  0]Assertion failed: Assertion failed:  [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\Engine\Private\AI\Navigation\NavCollision.cpp] [Line: 440] 
05-23 21:03:50.282 23429 23444 D UE4     : Attempt to build nav collision data for /Game/DieRed.DieRed:NavCollision_0 when we are unable to. This platform requires cooked packages.
05-23 21:03:50.282 23429 23444 D UE4     : [2016.05.24-04.03.50:282]  0]LogWindows: FAndroidMisc::RequestExit(1)

This started happening since I added a new blueprint staticmesh actor with simulate physics on.
I have set the actor to “character can step up on – false.”
There is no navmesh actor in the level – I don’t actually use a character or navigation, as the game is entirely UI widget blueprint driven and physics is mostly for eye candy.

What can I do to solve this problem?

Hi jwatte,

I’ve tried to reproduce this on my end, but I’m not able to get a repro so far for this yet and the only thing I’ve not successfully set up on my end is the distribution signing. While I’m getting that setup to test can you tell me the following:

  • If you remove this test asset from your build do you still get the crash?
  • If you leave the asset in, but set it to disable Simulate Physics do you get the crash?
  • If you disable Distribution Signing do you get the crash?

Also, if you have a simple repro project this could be helpful as well.

Thank you!


One suggestion is to try turnig of “Auto Create Navigation Data” in Project Settings under Engine - Navigation System and see if it goes away.

Thanks both for the suggestions!

I had actually tried most of the suggestions already, including removing the entity (started working again) and disabling navmesh generation (still asserted with the entity in,) but not the “disable physics” while keeping the entity in the scene.
However, I had set the computer to packaging a full package after posting this request for help. When I now started it up again to test the additional suggestions, the scene just works, without asserts, even though I didn’t change anything (other than the re-build that happens at packaging.)
So … sad engineer can’t reproduce it to debug it. Glad developer doesn’t have to worry about it unless it comes back. Win some, lose some …