Download

Attack delay

hello guys i would be happy if someone can help me with a bug towards the “attack” here my attack node:


my issue is the “delay”, if i remove the delay, the character can “spam” attack animation like a crazy which is a big issue however if i place the delay after the play montage nothing happen the player can keep spaming the attack animation, and placing the delay in any place before the animation montage the animation have a “huge delay” while clicking before the animation play even if i reduce the delay time still not proper work the player goes back to being able to “span” the animation, how i can proper set a “pause”/delay between each time the player press the buttom for him not be able to “spam the buttom”, i’m also having a sort of “same issue with jump, i’m using a anim montage for jump, and when the character is in air the player can “spam jump” to make the character shake like crazy while in air”, how i can prevent this to happen? i way to “disable” the input while in air then whe get back in ground with the "on land input i can activate again the input to be pressed.

1 way : Don’t set the Is Attacking straight after the Input Action. Instead remove it and just begin with the Branch (IsAttacking). Now, from the first(top) output pin on the Montages, set ‘IsAttacking’ to True. On the ‘OnCompleted’ outputs of the montage, set ‘IsAttacking’ to False. This should do it.

Basically, once the player attacks, he can’t attack again until the montage is finished which sets the ‘IsAttacking’ back to false.

ok i’ve tried what you told:

however now after that the character is not attacking anymore, the attack become disabled with that.

yeah indeed, my bad :p:p:p:p thanks now it’s proper working.

edit:2 nvm i was able to fix it, now it’s proper working now, really thanks
here the nodes:

now i just must adjust the "dash attack again to it stop after the dash