Download

Attack Animation not playing

Hi guys, I’m fairly new to UE4 and having some problems here. Thank you in advance :smiley:

Anyway, I already made a similar project to this where I could make my character walk, run, jump, aim, and attack, using my original animations, and it worked. However, I decided to recreate everything using the new free anim starter pack from UE. When I press the weapon aim button (right mouse button), it doesn’t play any attack or aiming animations.

input.jpg

Fire-aim input.jpg

I added a camera switch in this project, something that wasn’t in my first attempt. This cam switch and weapon aim are triggered by the same button (right mouse button). This cam trick works when I click RMB. I tried to delete the whole camera switch just to test if that was causing the issue, but it didn’t seem to fix the problem.

Cam Aim.jpg

(camera switch in action) (left: off - right: on)

bf722802469a4b1dc71db1789cc68313433a3e56.jpeg

The attack animations work perfectly when I tweak it in anim blueprint. It even plays the aiming and firing animations when walking or running, and the aim pitch and yaw works too (although not shown in the image).

4d032ae52543c1ce58690b97f61e931740ccdbc1.jpeg

The image below is what’s inside the Aim State

e9b6e8e9a64f43406ccc48dc271bfc102cc5a20e.jpeg

I replicated the exact same work that I did before with my own original animations, the one that works, but it doesn’t seem to work in this project.

da49c4d6c4145c804339e1f9880e1f0a72a0a39f.jpeg

(continuation of the image above)

0092d06489e5b9329fc0a1fca3ca3190c6644ad6.jpeg

not sure why :frowning:

Can any please help me?
Thank you very much. :smiley:

What stands out is the firing action is a flip flop Boolean so what we would need to see is the argument that gets the action into and out of the state.

Something else that stands out is it seems you are trying to get and set the same variable local rather than casting for the input from the Dude_BP.

I’m fairly new to this engine and didn’t have the time to work with blueprints till now, but as I see it, you need to make a node from your aiming tab “set” to when it’s true “play animation” and same goes for firing.
As it seems now from the pictures, it should do nothing because when the player activates the button for aim or fire and the boolen set is true, you don’t specify what you want it to do next, it just stops there.

EDIT: Now more pictures showed up :smiley: Sorry for my network… So I don’t really know if my above statement will help…