Download

Attack anim not playing

Hello everyone, let’s just skip the pleasantries and get down to business.

I’m using the FPS blueprint.

I’ve added my own skeletal mesh and animations.

I get motion animations to play, no worries.

But now I’m getting into weapon animations.

I used the FPS gun as a base, added my own attack anim to my skeleton. Made a montage for it.

In mycharacter blueprint.
I switched out Mesh1p for Mesh because that is what i’m using. Don’t know if this is significant.
I kept the get anim instance and only changed the montage to play from the fpp to my own animation.

The system compiles no problems there.

When i press attack the ***** spawn as usual but my animation does not play.

I dont know why, does it not override the anims currently playing?

Do I need to blend in the Anim, the FPP_gun doesnt have any blend set up i can see.
eb0798a15faae730942a30c29d1d16f8f9cc5f01.jpeg
mycharacter blueprint.jpg
I don’t mind if things look like ****, at the moment i just want them to work :slight_smile:

Oh come on, b-alls is censored?

What’s your Anim Graph look like…I’m just curious where “Attack” is on it and if it would override your Fullbody node…try and put in “Fullbody” (if you’ve not deleted it in the animgraph) and see if it plays…if not change your blends to 0 and see if you can see your animation…but it looks like from your picture your animation should be long enough for this not to matter…

I tried that late last night and it worked, thank you.
But it feels more like a hack than actual solution.
And how come the FPP-arms version doesn’t need it?

Good…happy it worked…

While I’m not positive what went south with your set-up due to not having a pic of your anim graph I’m guessing you might want to check out the “setting up the anim graph section” - https://docs.unrealengine.com/latest/INT/Engine/Animation/AnimMontage/index.html#settinguptheanimgraph

If you wish for the player to be able to move then you need to create a new Node in the AnimGraph likely called Upperbody or something of your choosing and the animation will only play on the Upperbody (or wherever you set it up to play depending on the results your looking for) while blending the (likely named) lowerbody node to create a final animation…
http://youtu.be/73FloYxQNUs?t=38s
All upper body doing one thing and lowerbody doing another but together they create Fullbody animation…

If you want an animation to play on the characters Fullbody with No variation like plenty of Action games (the player no longer can control the movement while the animation is playing) then use Fullbody.
http://youtu.be/EhKZ5wLY3O0
same animation on the entire characters fullbody exactly the same everytime…the player can rotate the character towards an enemy but they’ll be playing the animation no matter what…

hope that helps…let me know if I’m just way off the mark on what went south

whoops…forgot about this part…
The most of the anim montages use the Fullbody node as well (a little silly since there’s no body but still) … Looks like they created an Upperbody (as most games do) an Aiming node (as most shooting games do) and a Normal node…I didn’t look into what they used there normal node for but still 3 Fullbody animation montages…

Thank you, I’ll try this out after work tonight, and i’ll post a pic of the animgraph.

I tend to learn by doing instead of reading, I throw my self in, get to a problem, try a bunch of solutions, check tutorials and documentation first when I’m at that point. I have so much to learn about how it all works.

animgraph.jpg

Here’s the animgraph, it was simply the FPP anim graph, to begin with, when I got it to work I just added the attack part.

Maybe it can be added in the state machine instead?

Does it actually have to be called UpperBody ? Or can i call it anything and define it which bones are to be animated?

Yeah you could change animations through the state machine but that may end up in a ton of different states…depends on what your doing I guess…
And yes…You can name the Nodes to whatever you’d like…Doesn’t have to be UpperBody at all…