Download

Attaching smoke to an actor that moves.

I use ‘spawn emitter attached’ or ‘spawnactor blueprint effect smoke’ and then ‘attach to component’ nodes to make my actor start smoking. This works fine, but the problem is when the actor moves. There is a nice looking column of smoke, but when you move the base of the column, the top part also moves along with it, which would be impossible in real life.

I at least managed to make the smoke stop rotating along with the actor, but the whole particle effect is still treated as one solid object when changing location.

In particle effect you need to change coordinates from local space to world space.

That’s it, thanks a lot! I spent ages trying to fix it with different nodes and actor settings, but I didn’t think to edit the particle blueprint.

For anyone else who reads this with the same problem, open the particle blueprint, go to the ‘emitters’ tab, click on ‘required’. Now on the left under ‘details’, go to the ‘emitter’ sub heading and uncheck the box marked ‘use local space’ (version 4.23).