Attached weapon gets culled when partially out of view

I have a strange issue.I have a weapon (skeletal mesh) attached to a character (hand socket).I have FPS camera from the default “MyCharacter” blueprint controlling it.Now,when I look at the weapon while most of its volume is in the camera frustum- it is visible.But once half of it gets out of the view the whole weapon disappears as if it is getting culled.


When pitching the camera a little bit higher the weapon disappears:

Where do I enable them?

Yeah,I see now,both AABB and sphere are at the pivot point which is at the side of the weapon.How do I adjust them to contain the whole mesh?

Can you enable the bounds visualization (Show bounds)? You might be nulling the weapons bounds or not having the whole weapon within them.

The issues is that the bounds of your mesh are not set to cover your whole mesh. Using a static mesh this can be changed by adding collisions to the mesh itself (the collision option on the upper toolbar in the static mesh asset view) while a skeletal mesh requires to be setup in your external tool (max, maya, blender, etc). Just import your skeletal mesh with proper bounds or collisions and it should fix your issue.

Sorry for probably a stupid question but how do I set bounds in the modeling program? I exported from 3ds max and didn’t have any bounds geometry but the weapon mesh only.

It’s not a stupid question :smiley: Indeed the topic is quite interesting :smiley: The easiest way to handle the bounds of a skeletal mesh is to add a physics asset, then the engine will recalculate the bounds.

There are some resources out there that show how to export collisions within the FBX (I will make a test tomorrow hopefully). This will then ensure that the bounds are recalculated.

Another option is to use the bounds if the parent node when attaching the skeletal mesh to your character mesh.


I had this exact issue and I thought I was going mad. Your physics asset suggestion was spot on. Turns out I had some small bones out near the edge of my bow that didn’t get automatically added to my physics asset, so I had to tweak it a bit so my whole skeleton was included in the physics asset. Now the mesh renders all the time even when just the tip is in camera view! Thank you!