Attach to bone changes position and scale

It worked before and now suddenly it does this weird thing where it changes the scale and position when I attach a simple dynamic BP actor to a bone of a simple skeleton mesh BP. The scale of that simple dynamic mesh BP gets like 10 times the size and position slightly offset.
There is no animation playing while it gets attached.
The dynamic mesh BP is spawned.
Using 4.6

Hi Davision,

In order to reproduce this, could you list specifically step by step what you are doing when this happens and list what specific blueprints and skeletal mesh you are using? For example if you are using an Epic asset, list the specific one. If you are using your own asset, please be as descriptive as possible, so I can recreate the asset here.


Yea, it basically broke the whole game I started for Ludum Dare and I made then a whole different game. I tried to recreate it now with content example assets, interestingly it crashed a few times randomly in the level of my project while trying to. I ended up making a new level then using the dummy character of the content example but it did not happen there. But the same thing happened when using my skeleton instead. In any case it is very strange because I don’t see why the bone could manipulate the scale of the attached object.

Skull skeleton file:
(Note: the mesh looks a bit funky but the bones is what matter and what I use in my game)

Simple setup, the spawned BP can be anything, just use a basic shape and make a BP out of it. The skull skeleton is just simply dropped in the level. The spawn transform can also be anything:

Here is how that bug looks. On the right is the real size of the sphere, in the middle you can see how big that sphere gets when attached to that skeleton. It is actually exactly 10 times the size:

I also tried all those attach settings but they did not change it.

I was able to open the skull.FBX but unable to open the uassets. I think this is because of the extensions. I tried to change them manually as shown in the picture but it did not work. Can you try to resend them with the .uasset extension (as opposed to “COPY”)


Hi Davision,

I have not heard back from you in a few days, so I am marking this post as Resolved for tracking purposes. If you are still experiencing this issue, please respond to this message with additional information and I will offer further assistance.


I have found out now what the issue was. I had the FBX export scaling settings set to centimeter instead of the default decimeter which then resulted in that behaviour. I think I just didn’t see that instantly as the issue because the animations first overwrite that different scaled export setting and when I then had then reimported the animations later it was all broken.

alt text