"Attach actor to component" results in mysterious crash

Hello everyone,

I’m not entirely sure if this is the right place for this problem… but it is related to my blueprints after all, so I’ll just give it a try:

Right now I am trying to attach an actor (which basically consists of just one static mesh) to a socket of a skeletal mesh (my player character) via an “Attach actor to component” node, triggered by the press of the button “O” (just for testing purposes).
The attachment itself works pretty well: I press the button and my character takes the mighty sword dummy in his hand.
But when I try to move the character after that, this strange bug occurs: At a random time, between “instantly” and “after 1.5 seconds” after I started to move my character, the whole editor freezes - and not only the editor, but my entire system as well. No bug, crash or error report or log, just a system wide, complete crash. Not even Ctrl+Alt+Del does work anymore; the only option I have is to press the reset button and restart my system.

At the moment I’ve completely run out of ideas. I’ve tried it with multiple objects with multiple physics and collision settings, with or without welding, with and without parts of the AI Controller that drives my player character. Nothing seems to have any influence whatsoever.

Additional info:

  • UE 4.9
  • (Modified) version of the Top Down Template
  • The Player Character is driven via an AI Controller. The Player Controller writes variables to the blackboard; the AI then uses these variables to execute “Move to” tasks (works fine without the sword).
  • The sword object has no collision, so the mouse-raycast that determines where the player character should move to can’t “see” it. By now I’m pretty certain that this is not an AI issue (which was what I suspected at first).
  • The problem occurs between 0 and 1.5 seconds after my character has the sword attached to him and started moving again.
  • I use a custom skeleton and mesh that I derived from a software called “makehuman”.
  • I tried this with multiple collision settings to the player character’s meshes - no effect on the problem, though.

System Specs:

  • Win 10
  • AMD FX8320
  • R9 285 (latest drivers).

I’d be really happy if someone could give me some tips here or has an idea on how to fix this. Help me, Obi-UE4 Comunity, you’re my only hope!
Sorry for my English and thanks in advance. :slight_smile:

Maybe something related to the animation blueprint?

The animation blueprint is fairly basic: It just checks for the velocity of the pawn and sets the “speed” variable (float) of the 1d animation blendspace accordingly; then it looks for a boolean variable in the TopDownController called “IsAttacking”. Without the sword, this works absolutely fine: It can run, it can walk, it can punch things…
The funny thing is: The animations themselves work fine when the sword is attached too - for a maximum of 1.5 seconds at least, after which it crashes.^^

Hello everyone and sorry for the bump, but I came across some additional information that I’d like to share (and confirm).

Atm I think it’s the display driver of the R9 285 (my graphics card); which is pretty much the same card as the R9 380 btw.
I’ve set up a new project that gives me my mysterious crash and uploaded it, and I’d be eternally grateful if some of you would help me debugging it: Just open it up, run the whole thing in viewport, press “O” (which attaches the sword to the characters hand, and yes, I know it looks terrible^^) and walk around for a few seconds.
If I’m right, then everyone with a R9 285/380 should get some kind of crash; everyone else should be absolutely fine.

Link: Reference_48.7z

Thanks in advance!

p.s.: I tried to start the UE4 launcher with “-OpenGL” added to it, but it always crashes on start up (not the editor, but the launcher itself). Is there any kind of workaround?

I tried it, and it worked fine for me. Nvidia GTX 760. Do you get any crash logs?

Afaik there’s no log.

EDIT: The problem doesn’t occur when using other APIs, like OpenGL or D3D12!