Download

Attach Actor to Component Doesn't Work if Physics has ever been enabled

Ok so when I try to attach my Shotgun_BP to my Player Character’s Camera Component it doesn’t work. - well it sort of does but the component does not
However when I disable physics simulation in the BP-editor it does work.
But when I disable physics simulation in the Shotgun_BP it doesn’t.
Even if I have the physics simulation enabled then disabled in the same Exec line it does not work.

Here is the world location of the Staticmesh Component while the actor root is attached to the camera
397f75c8a1f966727d48cb826111ced42f1f42ec.jpeg

When you set an object to simulate physics it appears it looses it’s parents. So when you tell the object to stop simulate physics you have to attach back the mesh to a parent in the actor.

1ab349a7aa810efdaccf6200b1607178eac8aa88.png

2 Likes

Thanks !! that worked with no hassle Tekoppar :slight_smile:

How exactly? Somehow I can’t see the picture you sent, sorry.

i am having similar issues but i can’t see the image, is it possible to send a link that is directed to external source, like google drive or something?

I figured it out, it seems to be a glitch that occurs when the root of the actor isn’t the active physics component. I had a collider that was a child of a scene component and the exact same issue occurred. When I made the collider the root of the actor, everything worked.
I suspect it’s a heirarchy issue on the backend, but my solution spits in your face if you want to adjust the position of your collider relative to the actor origin, so my quick fix is to make a root collider set to ignore all other physics layers to act as the root node and its children will handle the collision shape