Download

AsyncLoadingThreadEnabled - How to get it working / Check it's activated

Hi,

Since 4.8, Asyncload is not true by default.
I tried to reactivate it to see if I can save some loading time, but sadly, I can’t get it work or “check” that I set properly the variable.

Can someone tell how to check / setup this variable?

In the 4.8 release, it is said that you should put it in “Core.System”, but in the Engine code, the variable seems to be a s.AsyncLoadingThreadEnabled in Core in [/Script/Engine.StreamingSettings].

Thanks for the feedback.

/Runtime/Engine/Classes/Engine/CoreSettings.h

as a protected member of UStreamingSettings class:



UPROPERTY(config, EditAnywhere, Category = PackageStreaming, meta = (
                  ConsoleVariable = "s.AsyncLoadingThreadEnabled", DisplayName = "Async Loading Thread Enabled",
                  ToolTip = "Enables separate thread for package streaming. Requires restart to take effect."))
uint32 AsyncLoadingThreadEnabled : 1;


Yep already see it. But where to set it in the ini file?
More AsyncLoadingThreadEnabled : 1 means it’s true by default whereas in the patch notes they said it’s false. Quite confusing.

In the path notes, they said to put it in Core.System, but no where, I can find the “System” setup for this variable.

Last, once activated, how to checks it’s working properly?

Thanks,

Last time I tried assync loading on 4.9 with the tutorial from

it all still worked withouth me setting any variable in a ini file. So not sure about this one. Maybe the thread is enabled automatically at some point?

This is not the same things. Here you are doing manual async loading when you need something specific.

The new functionality is to AsyncLoad all the assets ingame by default.

“: 1;” means the variable uses only 1 bit.

In order to enable the async thread you need to put

[/Script/Engine.StreamingSettings]
s.AsyncLoadingThreadEnable=true

in DefaultEngine.ini