Association .uproject / unreal are broken


I uninstall unreal, then reinstall it on another drive. But the association between .uproject are broken.

If I associate them manually, I dont have the utility to make C++ project when I right click on a UProject file in the windows explorer.

Someone Have an idee how to do without réinstall another time please ?

And if not, what is the good exe to associate .unreal file ?
UnrealEngineLauncher.exe ?
UE4Editor.exe ?
UE4Editor-Cmd.exe ?

They are all correct to launch a project, but not to have the utility with right click.

I am still plagued by this also. I have no idea why this happens but it does occasionally. Recently it started and affects all projects, all duplicated projects, and new projects.

I cannot fix it by changing file associations or changing the engine association from the Epic Launcher.
I also have tried verifying and reinstalling the engine and changing associations as well.
Lots of restarts and re-installs while changing settings and nothing seems to work.

I really don’t know what else to do.

I’m using Win10 Pro currently but I would also have this happen on Win7.

For some reason my UnrealVersionSelector does not even exist anymore. Even after reinstalls and all. I’ve checked the registry for the correct setup; here is what it looks like currently:

The unreal version selector exists in my github builds of ue4 but even those .uproject files associated with it do not have the correct associations.

This has been happening occasionally to me for about a year and a half and there has never been a dependable way to prevent it from happening or fix it. Usually I am just stuck with work stoppages if I need to fix something and I can no longer build it VS. It would be great if those same right click commands where available from somewhere else (such as inside the epic game launcher) instead of just being so undependable.

I’ll probably just have to wait another week and keep messing around and it will magically return.

Any luck mmanesse?

It seems like the accepted answer here is a dependable workaround, at least for now.

This is such a pain. I’m still stuck with it. I can do this fix to generate files and open the project from the engine launcher to change the engine. Anyone find any dependable fixes to make this system work?

I can only update the engine version by dependably by cloning the project from the engine’s editor open project screen.

Is there no dependable way to carry out these basic project tasks aside from the context menu of the often broken file association. It seems to be such a common problem. :frowning:

Running into this same issue at the moment.

The Epic Games Launcher no longer prompts me to say there is no file association and when I try to open projects in my Library I get an error stating no app is associated with .uproject

Recently had to reinstall Windows. Installed UE4.13.2 to look at an older project I was working on. Everything worked flawlessly. Decided to downloaded the latest version and start a new project and it all worked fine, however, whenever I try to re-open the project from my Epic Games Launcher Library by double-clicking the project I get this error “This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel.”

I went into Default Programs and set the association to “C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64\UE4Editor.exe”. If I click on the .uproject in Explorer it works fine, but the Epic Games Launcher still gives me the same error. I tried restarting the launcher then I tried restarting Windows; no luck.

I found an answer elsewhere:

Take this file: “C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealVersionSelector.exe”.
And paste it into “C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64” then double click it.

That fixed my problem.


Thanks @kenmorechalfant this did the trick for me.

Fixed it for me too, Thanks kenmorechalfant!](

Had the same problem with UE 4.20, this still did it for me! Thanks


Dude… you rock! Thank you!


I was getting a headache banging my head against the desk so much :stuck_out_tongue:

kenmorechalfant Thanks :slight_smile:

Hi all, I’m trying to generate visual studio files for my project, but the Unreal context menu items are not present.
Unfortunately this solution did not fix the issue for me… I’ve also tried manually running UBT on my project in order to generate the project files, but could not see any results from that.
Does anyone have any ideas? Thanks in advance.

Just a note to those that end up here due to the error “Couldn’t set association…” - this error occurred for me when there was a syntax error in the <projectName>.uproject file. In my particular case there was a comma missing in a list of parameters due to my own editing error. Since the uproject file gets generated and updated mostly by the engine this note is only relevant if you had edited the file manually and mistakenly. I bring it up because the error message is misleading in this particular case and sends you off in the wrong direction.

Bump since this is a top google hit for the error "Couldn’t set association for project. Check the file is writeable”. Spaces in the top level directory name can cause this misleading error message.

For example:

  • “E:\Projects\MyGame” - generate project files works, no errors :cool:
  • “E:\Projects\My Game” - generate project files fails, with above error message :frowning:

thank you!

U saved my life

Worked here, thanks!