Download

[Assitants Needed] Can anyone help me fix this?

Notes Before Reading : Wood was used as a example for this post in that is why when I say PrimalItemresource_ i am referring to all of the trade ables currently in my mod.

Hello Everyone,

I have got a huge annoying bug in my mod and I am hoping you can help me fix it
Link : http://steamcommunity.com/sharedfiles/filedetails/?id=514887130

By default the normal ark game does not have Engrams Or Crafting Recipe For Items Like Wood , Thatch , Hide <Most Collectables> , In my mod I want these Collectables to be trade-able <Example : I’ll give you 2 thatch and you give me 1 wood> to achieve this I want to give Wood a crafting recipe and make it only craft able in my new crafting structure obviously to do this I would have to edit the PrimalItemResources_Wood , so I search for this file in the game folder and found it I added the engram <I Duplicated EngramEntry_SparkPowder and change it to EngramEntry_Wood and then changed it to connect to PrimalItemResources_Wood then simply added to master engram list Note : EngramEntry File are in my mod folder PrimalItemResources_ are not> then I went into PrimalItemResources_Wood and added 2 thatch to Base Item Craft Resources <added a crafting recipe> finally I added it to only be craft able in my structure only

Here comes the problem…

When I edited PrimalItemResources_Wood I did not copy it to my mod folder I edited it in the normal Game folder so when I cooked and tested my mod it only added the engram and no crafting recipe

<Screenshot for above : http://imgur.com/ipdCACl,P55XWTS,Wjr9aJK,BssTrq9,aIfjSrO,UsmZf6k – if clicking on any of them it would crash the game , the BlueprintWood seen in photo is a glitch that was patched after this photo was taken>

So I decided to try copying the PrimalItemResources_Wood and having a duplicate in my mod folder but that did not work

Another way I tried was completely moving the PrimalItemResources_Wood to my folder and that worked but led to another problem : basically moving it to my folder is a bad idea because if I was to craft for example a Wooden Wall <or anything that requires wood in it recipe> it would not recognise that I have wood in my inventory and would only work with my trades now obviously I need it to work with normal game and my mod

But I don’t know how I can do this

Solutions I have tried

Create Duplicate of PrimalItemResources_ and put in both folders - Failed , did not make a difference

Create Child Duplicate of PrimalItemResources_ and put in both folders - Failed , still did not make a difference

If you guys have any suggestion on any solutions please leave a message and I will try and tell you if it fixed

I have changed the post to a completely long detailed version FULLY explains my problem please take time to read it and try to understand it as best you can , I can not write anymore detailed then this.

If you need me to take more screenshots of folders and files etc just write a reply saying so

And if you want to help me through Skype simply add me

Username : craftingcookie
Location : United Kingdom
Logo Description : Same as my YouTube yellow text saying CC and white circle behind text with a blue background

Bump bump bump

Bump bump bump

Hey cookie I’m making a mod similar to this and there is two ways you can go about it… 1 is make a CHILD of wood (not a copy) this won’t stack with wood but in all crafting, cooking and what not it gets treated as wood (lets you increase the stack size too). and 2 which the game not being optimized hurts a bit… make a copy of any resource and have the items “spoil” into wood. Hope this helps.

P.S. you have to copy the item by dragging it to your folder and then selecting (copy, move, create child) select it from there… you Don’t want to edit the default unless you want your mod NOT to work with anything or anyone elses.

as for the engram problem yes you can create an engram by copying any entry_engram blueprint but again copy it to your mod folder. and then assign it to the NEW primal blueprint (either the copy or the child you copied into your mod folder)

OH and also, the wood resource if you choose to child it … it IS NOT a craftable item by default so you have to check the “is engram” and “is craftable” and other options like that I’m at work now but if this doesn’t help send me a message and when I get home I’ll take a screen shot of my craftable wood and show all the options needed for it.

I I’ll try ur 1st idea

That 2nd idea is amazing but I have 1 question

I would want to make it so I can make a item in my structure example : I make thatch then it spoils into wood really quickly but the thing is how would I make that thatch do that without messing up the normal game

Simple you make a recipe for thatch (can be a copy of any primal resource doesn’t really matter cause your spoiling it into a different item.

I found that spoil is a great way to make things you create ( I made a scope but you can’t attach it so I spoiled it back to the orginal scope and then it “IS” the item so no more issues)

but I also learned because of the games poor optimization that spoiling to much to fast will cause huge lag spikes

OH I miss read that… you want “wood” to spoil into wood and you want “thatch” to spoil into thatch
the “words” are the COPY of the resource used for the engram to craft with … they are not the orginal

but again I found that it’s actually better because of the spoil lag… to just make a “child” of wood and turn it into a crafting engram and just use the new wood… the game treats the child as if it were the original except for the inability to stack it with the original. Though I did by accident find something interesting if make a copy of wood and don’t fix the name make it the exact same as the original it seems to overwrite the original but I did that by accident not sure if I can make it do that again and if that was all you have to do or not.

Thanks man I’ll try out both of your ideas when I can and I’ll reply back here to tell u if any of them worked