Download

Assimp - problem with link library to android application

Hi,
I compiled release version of Assimp to x86 and x64 platform as static library - without dll.
Everything is fine - game editor shows me good result, but building as android application returns error: undefined reference to (…).
Static libraries are inserted to <MyGamePath>/Binaries/<PlatformName>/<LibraryName>

<PlatformName>: Win86 and Win64
<LibraryName>: assimp-vc140-mt.lib and zlibstatic.lib

Also I copied these files to: <MyPackedGame>/WindowsNoEditor/<ProjectName>/Binaries/<PlatfomName>.

My Build.cs looks like:



// Fill out your copyright notice in the Description page of Project Settings.

using UnrealBuildTool;
using System.IO;

public class HomeProject : ModuleRules
{
    public HomeProject(ReadOnlyTargetRules Target) : base(Target)
    {
        PCHUsage = PCHUsageMode.UseExplicitOrSharedPCHs;

        PublicDependencyModuleNames.AddRange(new string] { "Core", "CoreUObject", "Engine", "InputCore", "Http", "Json", "JsonUtilities", "ShaderCore", "RenderCore", "RHI"/*, "RuntimeMeshComponent"*/ });

        PrivateDependencyModuleNames.AddRange(new string] {  });

        //PublicAdditionalLibraries.Add(Path.Combine(LibrariesPath, "assimp-vc140-mt.lib"));


        string PathToProject = "C:\\Users\\Pavel\\Documents\\Unreal Projects\\HomeProject";
        PublicIncludePaths.Add(Path.Combine(PathToProject, "Source\\HomeProject\\include"));
        string PlatformString = (Target.Platform == UnrealTargetPlatform.Win64) ? "Win64" : "Win32";
        string LibrariesPath = Path.Combine(PathToProject, "Binaries", PlatformString);

        PublicAdditionalLibraries.Add(Path.Combine(LibrariesPath, "assimp-vc140-mt.lib"));
        PublicAdditionalLibraries.Add(Path.Combine(LibrariesPath, "zlibstatic.lib"));

        // Uncomment if you are using Slate UI
        // PrivateDependencyModuleNames.AddRange(new string] { "Slate", "SlateCore" });

        // Uncomment if you are using online features
        // PrivateDependencyModuleNames.Add("OnlineSubsystem");

        // To include OnlineSubsystemSteam, add it to the plugins section in your uproject file with the Enabled attribute set to true
    }
}



Any idea?

#edit
I included plugin “RuntimeMeshLoader” - the same error message…

Hey, bro, do you finally successful ? Im doing same thing, kind of stuck,help plz:)

@Trixored Hi, I ran into the same problem. Did you get it solved. Thx.