Assets broke when I try to use them

it doesnt have the material applied to it. open the asset and ensure that it has a material set so that the material will be applied by default.

not work :confused:

you need to explain more. just saying “not work” doesnt tell us anything. tell us what your issue is and what you would like to be happening. from my point of view your asset had no material and now it does. if thats not the issue then tell us what the issue is so we can try to solve it.

When I start ue4, assets is displayed good!

but when I drag and drop them into my project, they become some kind of square (on second picture I used material from starter pack)

the squared version as you put it is how the mesh actually looks. the material that is initially applied has a transparency mask which makes parts of it transparent. if you apply the proper material to the mesh then it will look like you expect it to.

This doesn’t work even with the material that is bundled with the assets

is your material set to either translucent or masked? and what is plugged into the opacity? its the right texture and its displaying correctly it just isnt getting the opacity set correctly. also is the asset designed to be used with 4.19? they changed a bunch of things with materials in 4.19 so you may need to tweak the materials.

material settings:


it’s vegetation assets pack for older versions, but with another assets I have same problem

you see where it says blend mode opaque, that means theres no translucency. you need to set it to either translucent or masked. then you need to have something plugged into either opacity or opacity mask depending on which blend mode you used. you can probably plug the alpha channel into the opacity. the alpha is the bottom most pin on the texture node.

you will need a setup similar to the picture below.

thx a lot, but now I have another problem


Now grass is displayed better, but it’s visible from one side

thats an easy fix, if you look at my picture above at the bottom left you will see two sided with a checkbox, just check that box and it will render the material on both sides. you may also need to adjust some other settings like the shading model but for that you may need to just play around to get the right settings.

thanks again. could you help fix this problem with the resize


what do you mean? are you talking about a lod issue? GIFs arent very good for tying to see details (i dont like them in general). explain the issue so we can know what your talking about. you may need to open a new question on it if its beyond the scope of the original question.

if you move away from the grass by a few meters, then its size will increase

thats probably the lod. open your asset and see how many lods you have and at what screen space they are changed. if its the lod you can either disable them or change the settings so you dont notice when it changes. for example you could make it so the lod doesnt change until it takes up a smaller part of the screen (farther away) then when it changes to a lower rez version its not as noticeable.