Asset Manager creates duplicate asset types on engine reboot

To replicate:

  1. Create new blank blueprint project on version 4.17.2.
  2. Open project settings.
  3. Click on asset manager on the left.
  4. Observe the 2 types to scan already there. This is fine, they are suppose to be there. But watch this!
  5. Add a new custom asset type. Check “In Editor Only.”
  6. Close the editor. Reopen it.
  7. Go back to the project settings, then the asset manager.
  8. Observe that instead of 3 asset types to scan, you have 5. It creates two duplicates of the defaults and places them before the custom asset type created.

I’ve been able to replicate this 100% of the time.

Hello Leotics,

I have reproduced this issue and logged a report for it here

You can track the report’s status as the issue is reviewed by our development staff. We will follow up here if this gets fixed, but please be aware that this issue may not be prioritized or fixed soon.

Please let us know if you have any other questions about this issue, or would like to discuss how you may be able to fix this yourself if this is urgent for your project.

Thanks,

Thomas

Seeing the same issue as well!

Noticed the issue was marked as not reproducible @ThomasG, do you need any more information from us?

To follow up with this, I’ve also noticed that it does not seem to create duplicates if you uncheck the “In editor only” checkbox. So whatever checking that does is causing an issue somehow.

Thank for this new information, I have updated our internal report with this new information.

Sadly, on 4.25.2 issue is still here, “In editor only” is not checked

having the same issue