Download

Asset lit with dark black stripes. Help? :)

Hey there, I put my model from my university project into UE4, and created a simple material and everything, but the lighting looks all chopped up and there are a bunch of black stripes all over it. I put it into UDK and it looks fine, with essentially the same material. Anyone know what the problem is? I need to put the asset in-engine for the final part of my project and I’m going a little crazy here! :slight_smile:

Try increasing the light map resolution on the mesh. If that does not help, create a second set of UVs for the lighting (you can do that directly in UE if you want to give it a quick test). If you have created a second UV set for the lighting, don’t forget to set the UV set to 1 instead of 0.

Also, dont forget to build the lighting if you want the “real” results. You might also want to switch to production lighting (I assume you are on preview quality which is the standard).

I tried all that you’ve said and it still looks choppy. It looks like that even in the Asset Editor. I tried generating UV sets, increased the light map resolution. Still nothing :confused:

As IMX said, create a 2nd uv channel, but I would recommend you to do that in your 3d program (when you havent done that yet ^^): http://www.youtube.com/watch?v=z5yc-bKbHyc

Also take a look at this website: http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-05-common-problems-solutions.php (it’s for UDK, but it’s nearly the same in UE4)

The issue seems to have fixed when I saved a second .fbx of my asset and imported it with ‘generate normals’. Still it looks a bit darker than in Maya, but it seems to have worked. Still I wonder what the issue was?

Nice that you have solved it :slight_smile:

For those who have the same problem an can’t solve it with the “generate normals”: http://wiki.polycount.com/VertexNormal

Thank you very much for your help guys! Nice quick responses!

Just out of interest: Have you made sure the normals are okay in Maya? Certain poly operations in Maya can mess up your normals quite heavily. I’d like to know if you can get it right with the normals taken from the Maya export rather than having them generated at import :o

Well, everything looks fine in the Maya renders, there didn’t seem to be any issues and my lecturer couldn’t see anything wrong with it either, I can give it a go, reimport a slightly earlier version see if the issue is still there…I’ll report back soon :slight_smile:

Yes it’s definitely an issue with the normals, though everything seems a-ok in Maya, I have to import into UE4 with Calculate Normals. Do you know what the issue may be?

Could be a variety of things. You can try turning on the normals display in Maya and see if you have anything strange going on (and then reverse / align / average them as necessary). Also, I would generally recommend that you delete the history of a mesh (make a copy first - just in case). Also, you might want to do a cleanup (it’s in the Mesh menu I think) to see if you have anything odd doing on (lamina faces, nonmanifold geometry, etc) before exporting. Merging vertices is also a good bet if you have combined meshes, filled holes or something like that. Tesselating the geometry manually in Maya might also help if you have issues in UE.