Assertion failed - WorldPartition error on startup

Put simply - I’ve been working on a new UE5 project with WorldPartition, and all of a sudden whenever I load the editor it crashes with the following trace. I’ve tried removing temporary / intermediate folders, rebuilding project from source - to no avail. At the moment my project is unavailable because of this error (at startup). Any ideas appreciated.

Assertion failed: !StreamingPolicy [File:D:/build/++UE5/Sync/Engine/Source/Runtime/Engine/Private/WorldPartition/WorldPartition.cpp] [Line: 305]

1 Like

I’m getting a similar error. I also deleted the intermediate and saved folder but nothing…

Hi @Sheprekt, @halerooks,
I have looked into the World Partition source code for the UE5EA Engine, the failure line is in the middle of Editor World Partitioner, this has nothing to do with initialising the streaming.

I believe that commenting out this line will have no harm to the UE Editor. I have tried it on my UE50EA vs2022 repository, which will run on VS2019 only if you need to.
see Visual Studio 2022 Preview is 64 bit and compiles and runs UE 5.0 EA approximately 20% FASTER - Development Discussion / Unreal Engine 5 Early Access - Unreal Engine Forums

If this patch works tell me and I will submit an official bug report.

having the same issue trying to open one of my maps

I’ve had this and managed to fix it, but it’s frustrating.

If it’s crashing because the default level is the problem, and you don’t care about that level, you can open your project in a file browser, and just swap the name of the problematic level with another level. They are usually in the Levels directory in your project’s files and will have a .umap file extension.

If you want to try to restore the broken level, it isn’t pretty, but I’ve worked around this by, again, opening the project in a file explorer. You would need to have autosave enabled before the crash. This wouldn’t work if you’ve disabled autosave.

There’s a World Partition directory in your project’s files, and opening this up, there’s a directory with a huge number of other directories all with two-letter names like 5Y or 4C or BJ.

One of these is causing the problem. I don’t know any way to find out which one, but if you start by moving half of these directories to a temporary place elsewhere on your computer, and try starting the engine, you can narrow it down.

If you moved half of them and it still crashes, move that half back and try temporarily moving the other half.

Once you know which half is the problem, take half of THOSE files and move them, basically a process of elimination.

This isn’t perfect, because you will lose some of your level depending what was in the removed directory, and it takes forever, but it will get you up and running again with enough patience.

This is probably caused by a null reference, so something like, if your World Partition data relies on being able to find a specific thing, like a material (maybe?) and it can’t, it handles this very badly and crashes. It seems likely to be caused by doing a force delete, or an engine crash in the middle of a regular (but perhaps large) delete, but I can’t rule out other causes.

Easiest way to avoid this problem is not to enable World Partition, but that’s quite extreme.

Another way would be to avoid doing anything that requires a force delete, until you’re happy with your project. Then back up the entire project, do all your force deletes at once, and you can just restore the entire project if you trigger this error.

Hopefully someone with more knowledge can add more or better ways to this thread, until the engine is updated to better handle these situations.


We’ve started working with World Partitions as well, it is bleeding edge technology so bugs are expected. From our experience it happens if you delete a uasset from the content folder, but not from the level. This is an issue with the One File Per Actor feature.

These One File Per Actor files, kind of work like redirect files, so if you delete an asset from content folder but not the level this pseudo redirect file can’t find it’s source and crashes.

Hopefully you use Git or Perforce or some type of version control system. Or at least keep a backup copy from the day before. :grinning:

Easiest way to solve this is to navigate to your project folder into Saves/Logs . Open your log file after the crash, scroll all the way to the bottom. There you will see a stack track, scroll just above the stack track and look for the error(s). You will see something like:

/Game/SomeFolder/Environment/Walls/BP_Wall_Big_01 : Failed to load ‘/Game/SomeFolder/Environment/Walls/BP_Wall_Big_01’: Can’t find file. /Game/SomeFolder/Environment/Walls/BP_Wall_Big_01

You will need to restore that file(s). Then your map will load. Just be sure when you delete from the Content Folder, delete it from your maps first.

A side note, looks like One File Per Actor doesn’t show as referenced in the World Partition level, so you will not get any warning when you delete content.


Also having the same issue and tried everything…

Not a great solution if your map is developed but if you go into your projects files then in the content folder find the map you have set for editor startup map and delete it. That will allow you to open the project at least.

1 Like

This worked for me:
opening DefaultEngine.ini
and removing the value after “EditorStartupMap=”

Encountered same problem as OP after converting this specific map to WorldPartition earlier,
and closing the Editor and open again after a couple of hours.

Being able to open the project, I could then load the map succesfully.

CrashLog file

[2023.03.25-18.11.06:066][  0]LogLevelSequenceEditor: LevelSequenceEditor subsystem initialized.
[2023.03.25-18.11.06:092][  0]LogInit: Display: Engine is initialized. Leaving FEngineLoop::Init()
[2023.03.25-18.11.06:093][  0]SourceControl: Source control is disabled
[2023.03.25-18.11.06:094][  0]LogUnrealEdMisc: Loading editor; pre map load, took 8.458
[2023.03.25-18.11.06:094][  0]LightingResults: New page: Lighting Build
[2023.03.25-18.11.06:099][  0]LogWorld: UWorld::CleanupWorld for Untitled, bSessionEnded=true, bCleanupResources=true
[2023.03.25-18.11.06:099][  0]LogSlate: InvalidateAllWidgets triggered.  All widgets were invalidated
[2023.03.25-18.11.06:099][  0]MapCheck: New page: Map Check
[2023.03.25-18.11.06:099][  0]LightingResults: New page: Lighting Build
[2023.03.25-18.11.06:105][  0]LogAudio: Display: Audio Device unregistered from world 'None'.
[2023.03.25-18.11.06:108][  0]LogUObjectHash: Compacting FUObjectHashTables data took   0.61ms
[2023.03.25-18.11.06:325][  0]LogAudio: Display: Audio Device (ID: 1) registered with world 'Map_Prototyping'.
[2023.03.25-18.11.06:326][  0]LogEditorServer: Finished looking for orphan Actors (0.000 secs)
[2023.03.25-18.11.06:326][  0]LogAIModule: Creating AISystem for world Map_Prototyping
[2023.03.25-18.11.06:336][  0]LogUObjectHash: Compacting FUObjectHashTables data took   0.46ms
[2023.03.25-18.11.06:336][  0]Cmd: MAP CHECKDEP NOCLEARLOG
[2023.03.25-18.11.06:337][  0]MapCheck: Map check complete: 0 Error(s), 0 Warning(s), took 0.347ms to complete.
[2023.03.25-18.11.06:337][  0]LogFileHelpers: Loading map 'Prototyping' took 0.244
[2023.03.25-18.11.06:350][  0]LogUnrealEdMisc: Total Editor Startup Time, took 8.716
[2023.03.25-18.11.06:720][  0]LogOutputDevice: Warning: 

Script Stack (0 frames) :

[2023.03.25-18.11.06:739][  0]LogWindows: Error: appError called: Assertion failed: WorldPartition->World == World [File:D:\build\++UE5\Sync\Engine\Source\Editor\WorldPartitionEditor\Private\WorldPartition\SWorldPartitionEditor.cpp] [Line: 73] 

[2023.03.25-18.11.06:739][  0]LogWindows: Windows GetLastError: The operation completed successfully. (0)


I went a little more nuclear, I opened my project folder in VS code, and searched for EditorStartupMap and GameDefaultMap and cleared them in several files:

  • \Config\DefaultEngine.ini
  • \Intermediate\Config\CoalescedSourceConfigs\Engine.ini
  • \Saved\Cooked\Windows<YOUR_PROJECT_NAME_HERE>\Metadata\CookedIniVersion.txt
  • \Saved\Temp\Win64<YOUR_PROJECT_NAME_HERE>\Config\DefaultEngine.ini
  • \Saved\Temp\Win64\Engine\Config\BaseEngine.ini

This was a result of me clearing up assets and changing maps and deleting old template maps and ignoring that popup every time that said “blah blah replace references in ini’s” and i never went in and did that…

This worked for me!

Thank you, It worked!

As someone stated it, I managed to resolve the issue by renaming the map that was causing this, I could open my project again with a black empty map.
Couldn’t open the map again, because unreal seemed to have lost the link to this map after I renamed it.
So I managed to reload the map by going into File > Recent Levels > [your map] it worked again, dunno why but It’d take it.

1 Like

Thanks! That worked for me.

1 Like

Yes, just deleting the lines below worked for me:

You will have to set them again, but no big deal.

Thank you.

Thank You! This worked instantly for me :relieved:

Thank You!

Worked for me. Thanks…

You need to change the editor startup map if this happens, found in the ini settings. The map the editor tried to load on startup is in error.

Thank you! This worked.

1 Like