Assertion failed: PIEInstanceID != INDEX_NONE

I am trying to test in PIE Editor with a Server and Client running to check if i can connect to a Lobby but for some reason Soon as I join the Lobby with the Client the Engine Crashes and Pops this error ^^^^ Any Suggestions Error (Assertion failed: PIEInstanceID != INDEX_NONE [File:D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\LazyObjectPtr.cpp])

Same issue. Level works, but when I add a landscape I get the same crash when client logs into the lobby.

Having the same exact issue currently. I made a lobby screen, and when I click to join the game I created, it crashes with this error every time.

Same issue. Please help…

After numerous experiments I found out that if you want to add landscape to your map for multiplayer PIE and not to crash the editor, the map must have ‘World Partition’. Look into your map’s World Settings, somewhere in the middle there is a ‘World Partition Setup’ tab. You can create a map with World partition if you choose ‘Open World’ or ‘Empty Open World’ options. Documentation also says that it is possible to convert maps without World Partitions into ones with them : World Partition in Unreal Engine | Unreal Engine Documentation . I tried, but it didn’t work for me, but I didn’t try much. maybe somehow it works.
Anyway, creating new Open World map worked for me to solve this crash issue.


Thanks for your answer! This solved my problem and there was not much to find regarding this issue!
I submitted this in a bug report.

Thanks for your post, I had the exact same problem in my UE5.0 project. Switching to a map using World Partition prevents it from crashing for me too.

Thank you - same problem, same solution.

This resolved my issue as well. I am eternally grateful, thank you so much.

My map is based on the “New open world map” level and I still see this error when connecting through PIE. I can also see the “world partition” tab next to world settings which shows the landscape minimap. So I assume that world partition is correctly set up. Are there any specific settings I need to change in order to prevent it from crashing?


Update: My issue seems to be this one: Unreal Engine Issues and Bug Tracker (UE-156921)

Target fix is for 5.1

I found one solution you can run game with “Standalone Game” mode.

This worked for me too, thank you!