Assertion Failed : New World

Hello guys,

after some time I wanted to play ARK again and for some reasons it doesnt let me . I am trying to play on a multiplayer unofficial servers that runs mods.
Here is the output of the log file:

Assertion failed: NewWorld [File:D:\build\PC\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp] [Line: 10035]

VERSION: 279.281
KERNELBASE.dll!UnknownFunction (0x00007ffdb886f218) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FOutputDevice::Logf__VA() (0x00007ff65960e728) + 159 bytes [d:\build\pc\engine\source\runtime\core\private\misc\outputdevice.cpp:145]
ShooterGame.exe!FDebug::AssertFailed() (0x00007ff65960ecc5) + 178 bytes [d:\build\pc\engine\source\runtime\core\private\misc\outputdevice.cpp:220]
ShooterGame.exe!UEngine::LoadMap() (0x00007ff65a0c9435) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\unrealengine.cpp:10041]
ShooterGame.exe!UEngine::TickWorldTravel() (0x00007ff65a0c642a) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\unrealengine.cpp:9281]
ShooterGame.exe!UGameEngine::Tick() (0x00007ff659e082bf) + 0 bytes [d:\build\pc\engine\source\runtime\engine\private\gameengine.cpp:1143]
ShooterGame.exe!FEngineLoop::Tick() (0x00007ff658856945) + 0 bytes [d:\build\pc\engine\source\runtime\launch\private\launchengineloop.cpp:2421]
ShooterGame.exe!GuardedMain() (0x00007ff658850d8c) + 0 bytes [d:\build\pc\engine\source\runtime\launch\private\launch.cpp:140]
ShooterGame.exe!GuardedMainWrapper() (0x00007ff658857eaa) + 5 bytes [d:\build\pc\engine\source\runtime\launch\private\windows\launchwindows.cpp:125]
ShooterGame.exe!WinMain() (0x00007ff658857fd8) + 8 bytes [d:\build\pc\engine\source\runtime\launch\private\windows\launchwindows.cpp:209]
ShooterGame.exe!__tmainCRTStartup() (0x00007ff65b0bd3a1) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
KERNEL32.DLL!UnknownFunction (0x00007ffdb9233034) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffdbba51551) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffdbba51551) + 0 bytes [UnknownFile:0]

I tried to verify the integrity , it finished but still it crashes.

UPDATE: I tried playing on a official server without mods on TheIsland map and it worked so it has something to do with a mod or something like that.


I to am having the same issue, Ragnarok being the only map this happens on.

Happens in Modded or vanilla, also doesn’t not get resolved by reinstalling drivers/game.

Would really like to get into my own server and play this map now that its not just 35% done.


well i got the same problem but i was able to fix it.
In my case the Ragnarok folder was empty so i just reinstalled the ragnarok dlc and now it works.

I hope this is helping you guys

  • Tebutor