Assertion Failed Error - Installing and Launching UE5

Hi Everyone,

New here and coming over from the Unity scene. I’ve been really struggling to get UE5 to launch on my system. As far as I can tell my specs are fine for it to work as they are showing above the recommended spec but I keep getting the below error when launching the editor.

I’ve tried a fresh re-install, clearing the web cache but still get the same error.

I’m not a coding or Debugging expert, pretty much a beginner trying to dabble and learn so not even being able to launch the editor has already made this a bit of a jarring experience already.

Does anyone here know what is wrong (and/or if I’m doing something wrong??).

Many thanks in advance!

> Assertion failed: bGotReturnCode [File:/Users/build/Build/++UE5/Sync/Engine/Source/Runtime/Core/Private/Mac/MacPlatformProcess.cpp] [Line: 281]
> FMacPlatformProcess::ExecProcess(char16_t const*, char16_t const*, int*, FString*, FString*, char16_t const*, bool) Address = 0x10d6d9146 (filename not found) [in UnrealEditor-Core.dylib]
> FMetalDynamicRHI::FMetalDynamicRHI(ERHIFeatureLevel::Type) Address = 0x1572da397 (filename not found) [in UnrealEditor-MetalRHI.dylib]
> FMetalDynamicRHIModule::CreateRHI(ERHIFeatureLevel::Type) Address = 0x15725d60c (filename not found) [in UnrealEditor-MetalRHI.dylib]
> PlatformCreateDynamicRHI() Address = 0x10bc12615 (filename not found) [in UnrealEditor-RHI.dylib]
> RHIInit(bool) Address = 0x10bc13ff8 (filename not found) [in UnrealEditor-RHI.dylib]
> FEngineLoop::PreInitPreStartupScreen(char16_t const*) Address = 0x10b0d7826 (filename not found) [in UnrealEditor]
> GuardedMain(char16_t const*) Address = 0x10b0ce634 (filename not found) [in UnrealEditor]
> -[UEAppDelegate runGameThread:] Address = 0x10b0ea053 (filename not found) [in UnrealEditor]
> -[FCocoaGameThread main] Address = 0x10d67e771 (filename not found) [in UnrealEditor-Core.dylib]
> Unknown() Address = 0x7ff81a5cf9f4 (filename not found) [in Foundation]
> _pthread_start Address = 0x7ff8196be4e1 (filename not found) [in libsystem_pthread.dylib]
> thread_start Address = 0x7ff8196b9f6b (filename not found) [in libsystem_pthread.dylib]

My System Specs:
iMac, 3.6GHz Quad-Core i7, 16GB DDR4, Radeon Pro 560 4GB


I am having the exact issue you are and my mac specs are nearly identical to yours.
I’m running BigSur 11.5.2

I figured it out! (no thanks to Epic Support :smile: )…

basically, update or re-install Xcode and then do a fresh re-install of Unreal engine 5. That should do the trick.

Nice, very comprehensive solution there…