"Assertion failed: !bPostTickComponentUpdate" error when trying to run exported game

When I try to run my exported game (tried in all 3 development configurations), I get the following error:

Any idea what this is? Please help…

Thank you!

Hello Paragonx9,

Do you receive any of these same problems when trying to launch your game in “Standalone” from the PIE menu in the editor?

Can you also try to see if the same thing occurs when trying to package a fresh project?


Nope! I can launch it fine as standalone for Windows in the editor.

It does not happen, it only happens in this project.

Thank you for the help!

As this is happening only in your project, would it be possible for you to upload it so that I can attempt to debug the problem? If you wish for it to stay private, you can send a link to my on the forums instead of linking it here. [Here is a link to my forum profile.][1] If there are size concerns, you can alleviate some of it by deleting the Binaries, Intermediates, and/or Saved folders as those can be regenerated.

Alright, sent. Thanks for your help!

It seems like there may be some issues with the game’s logic itself. I’m also receiving a crash when trying to play the project in PIE that has something to do with AI. The logs for the packaged version also mention problems with an AI navigation function. Can you try taking out any AI controlled pawns from the game to see if the same issue occurs?

Yeah, you could be right, it’s a really rough draft after all. I’ll try when I get home, thank you!

We’ll, I’ll be. I created a new map with no AI at all, set it as the starting map, and it works right off the bat after packaging, plugins and all. So it is the AI’s fault. Any way I can fix this? Do you think it has to do with something in the tick event?

There is a lot to look at here without knowing much about the project myself. Based off the callstacks from packaging causing it to crash it should be AI related rather than the tick function. The assert that you’re getting about the tick function is more of a symptom of another problem.

Unfortunately since I’m having problems packaging with any level other than the main level, for whatever reason. I’m having trouble getting a callstack for that crash since that would require attaching a debugger to the packaged program before it crashes, which happens immediately.

Fixed it. I deleted the content of the level blueprint, it seems the issue was related to that part of the level. Thanks for your help!!