Assert Failed - TargerPlatformManagerModule.cpp

I built the UE4 solution using VS2013. The build completed without errors. On debugging, the UE4Editor.exe hit a breakpoint.
The output log is:
(UE4 output log -

I’m not sure what the breakpoint error means
(“LogModuleManager:Warning: ModuleManager: Unable to load module ‘E:/Unreal Engine/Engine/Binaries/Win64/UE4Editor-ShaderFormatD3D.dll’ because the file couldn’t be loaded by the OS.
E:\Unreal Engine\Engine\Source\Developer\TargetPlatform\Private\TargetPlatformManagerModule.cpp(459): Assertion failed
UE4Editor.exe has triggered a breakpoint”)

Can someone let me know what the problem is? Thanks

Hi aniruddha1991,

Would you be able to provide some additional information about this issue?

  • What version of the Engine have you built?
  • What solution configuration did you use when you built it?
  • Are you running the Engine through Visual Studio’s debug environment?
  • Can you provide a copy of your dxdiag information?

Please see this page for some additional information that may also be helpful.

  1. The engine is the 4.4 release.
  2. It is a Source build
  3. Configuration used during build: Development Editor
  4. Yes; I’m running the Engine through VS2013 debug environment
  5. Dxdiag (Dxdiag -
  6. Latest Engine log file: (Log file open, 09/02/14 13:50:35LogInit:Display: Running engine without a game -

I tried to reproduce this with both 4.4.0 and 4.4.1 built from source code, and was unable to get a breakpoint to trigger. Does this happen for you every time you debug the Editor?

These are the steps I performed, please let me know what you may be doing differently:

  1. Open UE4.sln in Visual Studio 2013.
  2. Verify Development Editor as the Solution Configuration and Win64 as the Solution Platform.
  3. Right-click on the UE4 project in the Solution Explorer → Debug → Start new instance
  4. Click Yes to build.
  5. Wait for the Project Browser to open.
  6. Close the Project Browser and Visual Studio.
  7. Open a .sln file for a game project created with that version of the Engine.
  8. Verify Development Editor as the Solution Configuration and Win64 as the Solution Platform.
  9. Right-click on the game project in the Solution Explorer → Debug → Start new instance
  10. Click Yes to build.
  11. Wait for the Editor to open the game project.
  12. Close the Editor and Visual Studio.

Does the breakpoint still trigger if you follow these steps exactly?

I don’t get past Step 4. After I click Yes to build, it starts building. It starts the build. It completes the build and the Debug starts. It starts loading the various symbols. It reaches the symbol for UE4Editor-ShaderFormatD3D.dll and then the break occurs. It pops up the dialog box saying “UE4Editor.exe has triggered a breakpoint” and ask me whether I want to Break or Continue. The project browser does not open and I can’t continue past Step 4.

I tried a few variations on building version 4.4 of the Engine and I am still not able to get this break point to trigger. Have you tried redownloading (not just unzipping what you already have downloaded) the source code and dependencies and rebuilding the Engine? I just want to try to rule out a corrupted file.

The problem is fixed. I guess I should have tried working with the Unreal Launcher first. I got a 0xc000007b error. I did the whole dependency walker thing and found the problem with the D3DCompiler_43.dll. So I replaced it, and now the sln builds and executes the UE4 Editor.
Thanks! Sorry if I wasted too much of your time