ASP character jump problem

So I downloaded the Animation Starter Pack and when I jump with the character it only plays the anination but doesn’t get any higher from the ground. I tried to edit the values but I haven’t found them. Maybe I am just lost but I can’t figure it out how to cure this problem.

Thanks for the answers, and have a nice Day!

In the ASP example character, it seems they have forgot to call the jump function after the velocity is set.
To fix, add a ‘Jump’ node to the character’s blueprint and wire it after the jump Z velocity is set.

Epic, have you looked at the blueprint? it’s a mess…

Hi Stickazzii,

While ULLS answer provides a workaround, it is not neccessary. Starting with a blank Blueprint project with the ASP imported, to get your character to jump (and all other actions) you will have to set up your Inputs under Project settings. Then you will have to create a Game Mode blueprint and designate the ASP_Character as the Default Pawn Class.

Let me know if need further support with these steps -thanks.

Hi , you should take a look at the new asp blueprint. I assure you that when adding the required inputs the character’s capsule doesn’t jump. The op clearly set up his inputs as he was able to trigger the animation. My answer is not a workaround, have you even looked?


I’m not sure my wording of “workaround” is correct. However, not only did I look, I rebuilt the project step by step starting with a blank Bluprint project and importing the Animation Starter Pack as I’ve described above. During this process I also looked at the blueprint pictured above for descrepancies and it looks exactly the same.

Hi , I added the 4.8 version of the ASP to a new project and saw that not only the Jump function wasn’t added to the blueprint but the values used to set the JumpZVelocity were identical to each other defeating the purpose. Also, there were a bunch of other odd settings in the characters movement component such as the gravity multiplier being set to a value of 1.5 for some peculiar reason. It took me some sorting out to make it usable. If you look at the image I provided above you can clearly see that the ‘Jump’ function is outside the comment box container, this is because it was not included in the blueprint. In fact, I was so perplexed by this I decided to search here to see if anyone had seen this, hence finding and answering to this post. In any case, I think I’ll drop this issue, hopefully any others that experience such oddities will find my answer useful.

Hi ULLS, I appreciate the feedback and can admit that I was making a mistake: by testing with the 4.7 version of the ASP and not 4.8, so thanks for mentioning that. So I have now retested with 4.8 and get pretty much the same results except the name of the character is listed as “Ue4ASP_Character” in the default pawn class drop down.(Instead of “SK-Mannequin” or just “ASP_Character”) Pictured below is the result: The character in the air with animation playing:

If others are having difficulty acheiving this, your solution may help. However, I cannot report it as a bug to be fixed as I am unable to reproduce the issue.

Again, thanks for your input.

Hi ,

Thank you for going through the trouble of setting up this test. Just so we are clear, could you confirm that the ‘jump’ function is wired up in the blueprint and the character’s capsule is actually jumping, seeing the jump animation in action doesn’t really confirm this for me, although he does appear to have slightly more height than mine did so I expect it is.

Just so I am clear, what I believe the op meant and what I have seen is that the capsule doesn’t leave the ground making it impossible to jump on to any raised geometry. As mentioned before the animation plays making it appear as if the character is jumping.

Apologies for dragging this out but I am certain that this blueprint is missing the Jump function, along with using bad values for the ‘Jump ZVelocity’.

Okay, I have said as much as I can now so I will leave it at that.



I see now… Yes, in my previous example the character is just playing the animation and the capsule is not “jumping” up as it did in the 4.7 version. I have made our Marketplace team aware of this and they are working to get this corrected ASAP. In the meantime, it appears these nodes were left out:


I added these and the character does indeed jump at this point. Similarly, users can user your solution as well. Thanks for you feedback in getting this sorted out!

Report entered: JIRA [UE-18460]. When this is resolved an update will be added to this post.

This issue has been resolved and the fixed version is available for download. Let me know if you encounter any issues with the capsule not lifting with the jump animation. -Thanks