As Sequence Finishes Playing, Camera Transforms to Character Camera Without Call

I am using a Cine Camera Actor and have it animating in a sequence. There are no keys at the end of the sequence, but as soon as it finishes the camera flies away to a random location.

I tried checking Keep State and Restore State but the problem persists. This has me scratching my head (or pulling my hair out, maybe pick one).

Any ideas from you all?

Thanks,
CorsairOfLight

I had a similar problem a while back and it turned out it was colliding with one of my assets. After stopping and resetting does it go back to original position? If it does might be something to do with the sequencing, the camera isn’t recognizing end point or something.

Thanks for taking a look, I’ve been stuck for a while.

Do cameras have collision that I’m not aware of? There don’t seem to be any assets nearby that would cause the problem to happen at any rate…do I misinterpret?

There are no keys at all in the last 6 seconds of the animation. So I’m not sure if the endpoint is able to cause that. I’m open to further suggestion/explanation on this as I am ignorant about sequence stuff.

I believe mine was in a capsule collision, I’m not sure might be a glitch or a small setting thing, it might be helpful to watch something along the lines of this to make sure everything is correct

Or you could try restoring camera after sequence is finished, you could bind an event to the sequence’s OnFinished dispatcher and call SetViewTargetWithBlend with it. Depending if you want it instant set blend time to zero.

I tried the restore and keep states-- no effect, unfortunately. And, the event dispatcher would normally be a clever trick to avoid the problem, but the camera needs to remain there for future sequences in the same spot (what I have going on is a control pad activating various functions on a diorama, all animated with sequences).

I will check out the vid, thanks for your time and energy on this!

UPDATE on this thread.

I discovered that the camera actually jumps back into the character blueprint I’m using in my game. However, there are no nodes calling for this, at all.