Array struct pins disconnect when you change the struct definition

This bug is killing me. It occurs when:

  1. you have a user defined struct created in blueprints

  2. you have variables on a blueprint whose type is an array of the struct you just created

  3. you have references to this variable on the blueprint (I don’t know all of the nodes that have the problem, but I’ve definitely seen it on Get and Length)

  4. you add a new variable to the struct and save it. In the last case that I experienced this bug, the type of variable I added was a user defined enum, but I don’t think that it’s limited to adding enums.

At this point, all of the array pins disconnect on my blueprints. The worst part of it is that if you try to compile in this state, there’s a good chance that the editor will crash on you, and it’s possible that when you try to re open the project, it will immediately crash again.

When you fix the disconnected pins in the project, there’s a good chance that the next time you open the project, they’ll be disconnected again as well. This happens for a bunch more startups, and then eventually it just stops happening, but by that point, I’m ready to update my struct and the whole process repeats itself.

At this point, I probably spend at least a quarter of my time dealing with this bug because my project is heavy on arrays of structs and I’m constantly updating the structs. It’s destroying my soul.

Edit: Well at this point my project pretty much can’t continue. I can’t keep up with all of the pins that I need to reconnect each time I do this. After about 20-30 crashes tonight, I can tell you that ‘for each’ loops that have been disconnected from my array nodes are causing crashes. I think that add and or remove nodes might do it too but I’m not positive.

I’m seeing this same behavior in 4.4, in my case I’ve got a custom BP class I’ve wired to access the array of another custom BP class. That accessed array is also an array of BP actions, with default properties of the array filled with some test data. Everything works splendidly, compiles, works…but whenever I close the editor upon reopening the level any pins on that array are disconnected.

Hi evillego6,

Which version of the editor are you currently running? Also, could you post some screenshots of the blueprint setup you described?

Hi TJ,

The problem has occurred for me from 4.1 to 4.4.

I’ve uploaded a few screenshots of areas where it occurs for me. They aren’t disconnected in the pictures, but the disconnect would be the pins starting from the Persistent Characters node and going to whatever it goes to. Persistent Characters is an array of a struct I created within blueprints, and the disconnecting occurs when I change the definition of that struct by adding a column or something like that. The problem occurs in game mode blueprints, level blueprints, and actor blueprints.

Edit: actually I’m having trouble uploading pictures on to this post, so I’m just going to put them on imgur. There are 3 images in the album -Disconnecting Pins - Album on Imgur

I am still not able to reproduce what you are seeing. Would you be willing to upload your project to either Dropbox or Googledrive and send a a link to download it by private message on the forums?

I actually just saw this again, or something very similar, however, instead of it being a custom struct this time I was using a class with a variable array containing a list of custom classes (not actors, but classes). I’d gone down that route due to hitting this problem with custom structs, but the custom arrays thing proves just as problematic. However, EVERY TIME I try and create a simpler repro test case for you guys things work… Similarly, whenever I try and create a more complicated project, this broken-pin issue (or worse) shows up. I’ll try again to come up with discreet repro steps a bit later, I guess.

Hi evillego6,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please feel free to post back here with additional information.

Thanks, TJ

im experiencing the same thing with 4.6.1. i can confirm the bug is still there and its quite a showstopper. hope there is a solution?

Hi tegleg,

Since this is a report from version 4.4 of the editor, what you are seeing in 4.6 could be caused by something different. Could you post this as a new report in the bug section? Follow the guidelines on this link and make sure to post as exact repro steps as possible. Feel free to include screenshots of your blueprint setup.

This is happening to me in 4.10.0.

I have a simple struct (3 properties) - any nodes using an array of that struct disconnect with every close of the editor. I even tried replacing all of the get/break/make nodes etc in the project with brand new ones but they still get disconnected.

This isn’t the first time it’s happened with my structs and since the problem has been around so long despite several reports, it seems like it’ll take more time than I have available to come up with proper reproduction steps or add any more info, which is why I haven’t posted a new report about it. What I can say is that I added a property to a struct and then removed it, I experienced an editor crash and from then on the problem occurs every start up.

Personally since I don’t use them much, I’m going to use an object rather than a struct to store the info I want, even if it is less efficient.

This is still a thing. And its extremly critical. It breaks the foreachloop function and theres an random possibility that all arrays break in all widgets at once.

This is no normal bug, this is a developing stopping bug that makes ue4 unusable.

Is there any kind of a fix for this? This is affecting my project really badly. Is there a workaround?

Hey everyone,

This exact report was an old issue that we couldn’t reproduce internally. If you have any repro steps or a test project that we can use to investigate the issue further, please post it here or create a new report in the Bug Report section.

Its amazing that you weren’t able to reproduce this internally as I’ve had this happen countless times across engine versions. Its simple struct arrays that are attached to other nodes. Change the Struct later. Restart editor. Arrays are disconnected. Since for loops don’t have an error when the array is not connected, its hard to keep track of all the blueprints that stop working because of the disconnection.

4.12 was just released and we still don’t have a fix for this?

Hi sbnewsom,

If you are having the same issue that Filly_The_Owl described above, I believe it is different than than OPs original report here. It is also likely a different cause, being nearly 10 engine versions apart.

If you have additional info on how to repro this, please post it here in Filly’s new report. Please include repro steps as precise as possible and exactly what you are changing in the struct (variable, type, etc).

We are currently trying to reproduce the issue in the Survival Game Template because we are still unable to repro the issue in a new clean project.

Thank you,


I am still getting this problem in 4.16. This is serious. Every time I open my project I have to go through multiple blueprints and reconnect the nodes.

Even worse, I get node disconnections that don’t lead to compile errors, i.e. when I’m setting one variable to equal another. So I have to manually go through every blueprint that references the offending struct. This is nearly an hour out of my day every day.

Hi Bob3DGames,

In Filly’s new post I mention above, this was reported as JIRA UE-31679. Follow that link to monitor the status.