Array of structure in blueprint won't remember changed values

In my game I have a blueprint labeled AchievementsCollection which has an array of a structure labeled “AchievementList”.

I also have a UI to display achievements using UMG which request AchievementList and works the information from there. However, the information always comes back the same – with data I had entered awhile ago in 4.9. I’ve tried to erase the entire list and start over but I still get the same results from the variable.

Also, whenever I tried to delete array length on an array of the same structure in another blueprint UE4 crashes. I know this would be nearly impossible to reproduce so I’m prepared to supply Epic with the project files privately.

Deleted the AutoSave folder just in case that was causing problems. I renamed the “AchievementList” variable and now the list shows blank instead of the new data I added.

Also, whenever I tried to delete array
length on an array of the same
structure in another blueprint UE4

To my knowledge you cannot delete an array length, use array->clear.

Somehow i can’t get exactly what you are trying to achieve.

Where is your array struct stored? inside an actor, the level blueprint, character controller?
Also: Make sure there is no dublicate blueprint with the same name laying around, so search your assets not only in UE4’s content browser, but also open your windows explorer and search for old files manually.

Here a general help for handling array structs:

Retrieve a certain value from an array of structs where a certain value matches a given value:

Sorry, when I meant delete an array length I was referring to within the editor, such as clicking the trash can to clear the array for example. It also crashed when trying to delete a single entry.

There are no duplicate names as far as I know. I keep my stuff fairly well organized.

I was able to resolve the issue by just making a new variable of the same type and swapping out all the old entries with that one. However, this could potentially be one heck of a headache if it happens again because I am likely to edit this information as I progress with the project.

i also noticed that creating and deleting a variable inside a blueprint does not fully delete it, since you cant create the same one again.
It can only be solved by re-creating the blueprint, seems to be an issue within UE 4.9 and 4.10 Preview.

Hi Distul,

I’m glad that you got it working. We are currently looking into improving Struct Arrays. It’s possible that whatever the root cause of this issue, it could be fixed when they are overhauled.

Hey StreakyCat,

I attempted to reproduce this but I couldn’t get your results. When I create a var in 4.8, 4.9, and 4.10 P2 > Name it > Delete it > I can then recreate a variable with that same name.

The engine seems to be caching something somewhere but I deleted every save and cache file I could find before taking the route I did in resolving my problem. I can offer my project if staff wants to take a look because it seems this issue would otherwise be difficult to reproduce.