Array nodes don't work in mobile

So i’v been having problems in mobile with some array nodes, “find” and “set array elem”
I’v made some tests and this nodes work completely fine in pc but when I launch on mobile they simply don’t work.
Can some body tell me if had this problem too, or if can be fixed?

Can someone at least test them and tell me if had the same problem?

Hello Colatran,

What sort of issues are you seeing with these nodes on mobile? I tried setting up a small test that involves the following blueprint nodes and I received the same results on Windows as I did with Android.

This results in the correct outputs, with Find getting element 2 and 3, where Element 2 is set to 2 by default and element 3 is set to 3 but is being changed to 10 by using Set Array Elem.

I’v made the same test as you did and worked fine,you did with a int array, but it looks like that only hapens when it’s a text array.
Can you test it?

I’ve reproduced the issue, where doing that same setup with a Text array has both of the Find functions return -1 but it seems that this happens in any cooked build, not just mobile. If you package for Windows instead of simply playing in edtior, you’ll receive the same issue. I’ll look into what is causing this, but it is not mobile specific.

Thanks Matthew J.