Download

ARKIT head rotation lost when baking to Control Rig

Using the metahuman sample project I try to combine a recorded facial anim with head rotation with the provided sample anim for the body (body anim of a talking person).

However, if I assign the animations for face and body in sequencer, the head rotation from ARKIT is gone. If I set the animation mode of the face to custom, it is back, but head and body are separated (see screenshot).

Also if I bake the facial anim to the control rig, the head rotation is gone. Does anybody know a way to blend both anims in sequencer while maintaining the head rotation from the face ARKIT recording?

This is interesting, I hope someone answers this.

1 Like

I believe this is due to the fact that the ARKIT head rotation is applied in the anim BP and stored in a variable inside the animBP. Since these variables are not exposed to sequencer their value is not recorded.

You need to go into Face BP Anim graph, make a Layered Blend Bone (there is one already there)
For sequencer go to the alternate Layered Blend per Bone you just added below the one already there, add 2 Layer Setup elements in details, and make them neck_01 and neck_02,
Now connect same way as the layered blend per bone node that was there.

2 Likes

Thank you Scott! This is very helpful.

Can you explain this in a touch more detail please Scott. I am trying to achieve the same but unsure how to go about your suggestion exactly. Thanks


Hopefully this will help

Many thanks Scott.

Thanks Scott, unfortunately I dont understand " For sequencer go to the alternate Layered Blend per Bone you just added below the one already there, add 2 Layer Setup elements in details, and make them neck_01 and neck_02"

Can you explain this? I go to sequencer, but it’s not apparent that there’s anywhere to access the new Layered blend per bone that we added in the first step. Thanks!

Once you’ve baked the face animation onto the Control Rig, select the face, switch it from “Custom mode” to “Use Animation Blueprint” and key the change. You can also toggle “Disable Post Processing” and key that.


Then, when baking the final facial animation sequence, make sure to tick “Evaluate All Skeletal Mesh Components
image2