Download

ARK dev kit memory leaks?

When using the dev kit, sometimes certain actions take a REALLY long time, at the end of which I run out of memory entirely (I have 16 gb). This happens more or less at random when I:

  1. Try to play a level inside the dev kit to test my changes (most common cause)
  2. Create or copy mod files
  3. Open blueprints (and other things) for editing (least common cause)

This is very annoying and, while it doesn’t make me lose much progress, it certainly ruins the experience and takes time it doesn’t need to.

That is not a memory leak. Even with my 32gb of RAM, SSD, and 3.8ghz i7, I still experience some very load load times depending on what I’m doing.

  1. What level are you playing specifically? If you are playing anything besides the testmap, keep in mind that if you run around (on say theisland) to different submaps, it will be loading up EACH submap you enter (each submap takes about 3-4 gigs of ram and this is EVEN with EMPTY submaps, so 4 submaps = your maxed with 16 gigs).

  2. Creating/copying mod files depending on how many you try to do at once will take a while potentially. It all depends on how much content it is having to load up for the move (yes it is literally loading up the assets into your memory for this).

  3. This is the least common cause, because all you are having to really load up in your RAM is that blueprint/other blueprints you have open and are editing.

If you are running the ADK on a HDD below the speed of 7000RPM, then load times are going to be VERY long I’d imagine. If that is the case here, if you can, move it to a faster drive.

Im gonna reply here to save space on the forum.
I have the same problem.
Its insane that it takes ages, AGES, to simply copy a blueprint to a folder.
30+ MINUTES to try to copy a file. I have to end task with task manager to let me actually use my computer because I cannot minimize the dev kit while its froze from trying to copy files or make any changes…

No, it is definitely a memory leak of some sort, or another sort of error that causes it to hog all the memory it can before crashing.

  1. I am using the test map. Sometimes it loads normally not using much RAM, sometimes it goes into infinite loading and then crashes because it gradually takes up all the memory.
  2. This happened a few times when I was moving 1-3 blueprint files around, so the amount of data transferred couldn’t be above 1 mb.
  3. That or because I mostly keep it open, so it is the action I do least often of the three.

Like I said, this error appears pretty much at random - I could be doing virtually anything when the dev kit freezes, starts devouring RAM and then crashes once the PC runs out.

Ah okay, my bad. In your OP you didn’t state anything about a crash, just running out of memory (thought it was cycling it like it should normally), hence my response.

In that case, then you may be right. It shouldn’t take more than 5-10 mins max to copy a single blueprint. Can either of you two provide a screenshot of the error that pops up possibly?

Edit: Are you by chance using any custom marketplace assets or UE4 assets? (are they even in your project folder?)

Well, the crash doesn’t necessarily happen, but it doesn’t even matter because I am forced to close the dev kit when I run out of RAM. And no, I’m only using the basic assets, and not even doing anything with them just yet.
The thing is, normally it takes mere seconds to do BP operations, and under a minute to start the level (the first time, even faster afterward), and it rarely takes more than 3 gb of RAM. Except when this stuff happens.
I’ll make a screenshot if I run into the problem again.
Forgot to mention, I’m using v200.5 for now.

EDIT: Forgot to mention another thing. This issue is always accompanied by the dev kit occupying 100% of my HD time with read operations.

The problem is doing ANYTHING for me, right clicking a bp will force freeze it.
When I create a folder, it will create but WONT create.
Even making a folder in the directory in Windows Explorer will work in Windows explorer, but the folder will not appear in the actual dev kit.

I can say its broken…
Even verified the dang cache of the dev kit BOTH launchers

I can confirm on the folder issue. Not having the BP issue.

So things were working tolerably yesterday after I posted this, but somehow got a million times worse today. You asked for a screenshot, I did one better and made you a video:
https://youtu.be/w1NlraFltyY
Not sure why the quality is so bad, but it’s enough to see what is happening.

How is it even remotely logical for the dev kit to READ and LOAD 11 GB of whatever from the disk to RAM, when I’m trying to WRITE a small level file to disk?

if it happens again, try to monitor what files are beeing read/accessed as i dont think the recorded error will be of any help
eg with a tool like: https://technet.microsoft.com/en-us/sysinternals/bb896645

Had this happen with the game itself today, for the first time. Similarly to the dev kit, it suddenly showed horrible performance and then crashed with the same error, although before reaching 11 gb of RAM.

Any word on this for a solution or coming fix?

I have been having this issue for a week on a map i am just painting and sculpting. Default size, no mods, no actors. After a few house of being open, taskmgr see around 4gig used but windows is reporting that i am out of memory and to close the dev kit.

At this point taskmgr and all memory managers are seeing 12gig consumed but you can not see what process is using all the mem, it just does not show up, which is indicative from what i understand as a memory leak or mismanaged unfreed memory.

ToNOTE: No other programs running, nothing but avast in background. 16gig ram.