Area shadows (for stationary lights) bug

Hi there,

So I started using the new “Area shadow for stationary lights” feature in 4.9 and started seeing some weird behavior. I have a landscape in my scene that serves as a floor to the entire level and when I turned on the area shadows feature I noticed that some other light sources would not light the landscape any more. They would light other objects, just not the landscape.

Steps to reproduce:

  1. Place an object in the scene to act as a floor.
  2. Place three light sources (Direction, Point or Spot light doesn’t matter) so that each light illuminates some part of the floor object.
  3. Enable “Use area shadows for stationary light” on one of the lights.
  4. Build the lighting.

When the lighting is finished, one or more of the lights will no longer illuminate the floor object. If you add more lights (that also illuminate the floor object), other lights will stop working as well. One workaround for now is to keep adding lights until all the original lights are still lit after building the lighting, and then setting the unwanted lights to not affect world.

Is there any way to get around this?

Could you report this to AnswerHub please?