Download

Are bone names case sensitive?

I’m trying to get root motion working on a custom skeleton (bought from Motus). The name of the root node is “Root”, and I noticed the name of the ThirdPerson default root node is “root” (note case). I’m wondering if root motion isn’t working because the bone names are case sensitive?

It’s only one bone, you should be able to rename it within the skeleton tree to double check.

I work a lot with bones but I have literally never tried to have a case mismatch, it’s easier to rename the functions or the bone to match then risk future version walking back the case transforms needed for the check and having the project fail - if they even have case transforms on bone names…

Thanks for the response!

I’m probably going to try to rename the bone and see. The reason I bring it up is because it’s not my functions. I think (I think?) the root motion is coded somewhere in the engine. The only difference I could find was that the root bone name was not the same as the default skeleton (the Skeleton from Modus was named differently). I read somewhere that the root motion only works with the default Unreal Skeleton mesh (which doesn’t seem like it can be right…), so I figured maybe the function in the engine that does the root motion was case sensitive, while looking for the “root” bone.

I run Linux so it’s pretty tough for me to modify the fbxs although I’m not sure if Blender can pull it off (if I export the mesh from Unreal to FBX).

It can, but it is something you need to work a bit with in order to get just right.
If you were working with the unreal mannequin I would suggest using my plug-in. You can try it either way - in fact, maybe you can utilize the skeleton by re-weight-painting your rig on the unreal bones.
I’s a lot of work just to get a mesh replaced, so I wouldn’t recommend it unless you know for a fact the bone hierarchy is the issue and you have no idea on how to make the bone structure on your own.