ARcore camera view black but tracking works

Hello, I’m developing an ARcore app that uses augmented images.

The first time I run the application after packaging it the camera output in my view is completely black, but my image tartgets get recognised and correctly tracked. If I close the app and then reopen it everything always works as expected.

If I remove all the candidate images from the “AR session config” object the application works the right way the first launch too.
I tried running the app with the launch button in the editor, building a developement package and building a shipping package and the behaviour never changes.

Removing all the candidate images from the AR session config and adding them at runtime seems to have no effect, no image gets tracked.

I tried both converting the example Augmented images project to UE 4.24 and starting from a fresh AR template project and the bahaviour stays consistently wrong.

Tested it on a Samsung Galaxy Tab S5e and on a Samsung Galaxy S8.

Has anybody solved this issue? Thank you.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Has anybody figured out a solution for this issue?
We are stuck on an project with 4.24 blueprints and so on and cannot downgrade to 4.23

Hi, any updates on this? I am currently on 4.25.1 and have run into the same issue. I cant seem to find the fix/ commit listed UE-87102 on the github repository.