Download

Archviz Ambient Occlusion Problem

Hi folks!

I attached a picture. I have very big ambient occlusion problem on edges of walls. My walls modeled properly and unwrapped. Also lightmap resolution is 2048 in ue4. Why i still have that problem? please help… If you see attached pic ou can also look at ao settings of scene…

Regards,

Oner

Can you post your world lightmass setings? Did you build the light in production quality?

It seems like lightmap problem… Classic light leaking.
After light building, did you see a message about overlapping on screen? Maybe walls have not thickness… Give some detail please.

first of all thanks for your interest…

i attached my world lightmass settings and also i attached a pic about my walls… i think thickness of walls are enough… After build i dont get any overlapping messages…

You have to seperate walls into smaller pieces. There are too much information for a lightmap.
By the way i think you haven’t any lightmap. At second image there is an information about UV’s : ** UV Channels :1** Where is second map?

to seperate the walls is a good idea. I dont have second UV Channel because these walls dont have any texture, they have just base color…

UE4 relies on UV2 maps to calculate lightmaps, so that’s probably your problem here. :slight_smile:

I prefer to make artificial lights movable (lamps, spots) and natural lights (sky and sun) static. Solves all those leaking problems.

Won’t that hit fps? Especially if you have multiple point lights in the scene fps goes down drastically.

Coming to the above problem, tweaking lightmass settings will definitely reduce the issue. In most of my projects, I tend to detach and separate the wall faces which are in view. This will reduce any artifacts and also will result in lower lightmap resolution.

Yes it will but at least I get no artifacts.