Download

Applying material issue on map

So basically I made this maze a few days ago on Blender and imported it into UE4 and the maze itself did not have any textures or materials applied on Blender. Now when I try to apply materials on UE4 for the wall it also covers the entire maze such as the floors so my question is how do I fix this?

thx in advance

That’s because your entire maze uses a single material, meshes aren’t like BSP brushes where you can apply materials on each face directly in Unreal.
For Meshes you need to go back to Blender, and make Two materials , one for the walls and one for the floors, then select all your floor polygons and assign them the new floor material, export to Unreal and you will be able to apply two materials now. ((You’ll see 2 material slots in the mesh settings))

Well I believe I did what you told me now my issue is that it does not display how it should, for example if I apply a material of red bricks to a wall, the wall only looks red with no bricks

UV mapping is also manual when making your own models, you will have to make a UV map for your model. It’s rather easy, you can look here Blender 3D: Noob to Pro/UV Map Basics - Wikibooks, open books for an open world for the basic introduction.
I would suggest approaching your walls in a slightly different manner. While though complicated models would almost always require you to make seams and manually adjust every uv island like in the tutorial, you can start off simple instead and use Cube Projection. Select all of your wall polygons, U - Cube Projection, and in the tools panel (T if you don’t see a bar on the left) at the bottom you can chose a scale for your bricks.

You can also create a bricks material in Blender so that you can instantly preview your UV map before importing into Unreal.