Apply compression doesn´t work 4.14.x

Hi, here is my problem, when I import a new animation
UE asks me to apply compression, I click Apply but nothing happens
and the button remains active.
When I restart UE and load the project it just crash because of this.
It happens to me only on 4.14(I tried every official hotfix).
I´m working on 4.13.2 at the moment, but 4.14 is better in my opinion
and my project was really starting to kick with it…sad
I hope you can help in finding a solution for this, thank you anyway!

Hi syq,

I haven’t seen the editor ever ask you to apply compression. The “Apply Compression” button is just persistent and only needs to be clicked after editing compression settings. When you import, it defaults to Bitwise Compression.

-Matt W.

Hi, thanks for your reply, I know it should not ask for compression and in fact on 4.13 I can work well
that behaviour happens to me only on 4.14…I will wait for 4.15 and retry, but I´m sure I´m not the only one experiencing this because I did another post on the matter and another user replied to my post with same problem…
thanks for your help anyway

my other post on the matter with the reply of another user saying the same…

There is no guarantee that this will be fixed in 4.15 if I can’t get the necessary info to enter a bug report. Can you attach the fbx for the skeletal mesh and animation that you’re attempting to import? If you’d like it to stay private, you can PM me a download link on the forums.

You can try 4.15 now if you want, but it likely won’t be fixed since we never had a bug report for it.

-Matt W.

I tried importing your files and it never asked me to apply compression. Is this still occurring in 4.14.3 for you?

You aren’t on a custom engine build, are you?

-Matt W.

Hi, No I´m not on custom engine, i´m using the official releases of the engine…
Yes this will occur everytime I try here on 4.14…I redid a lot of stuff in 4.13 which does not present me that problem, and I migrated everything to 4.15 when it became available, and now everything works well, I will stay on 4.15 I have no need to use 4.14 again…Just for your knowledge, I found one thing which doesn´t work in 4.15, or at least it does not behave like it did before, and is the “Set Child Actor Class” Node, it just make the child actor disappear, but I already found a solution for this…(about the compression problem, probably when I first opened my old project with 4.14 I converted it in place and maybe something corrupted, but it worked before, now I´m using safer ways to do things xD, and my project goes really good!!)Thanks for your efforts!!

Hi syq,

Please report the “Set Child Actor Class” issue in a separate thread. Even with a workaround, it sounds worth reporting.

-Matt W.

Any idea on how to fix the bug( compression not applying) for 4.14?

Try after disable ‘Only Check For Missing skeletel meshes’ in project setting-> Animation