Apply additive root motion works in preview but not ingame

Hi! I’m on UE 4.12.4

I have an enemy moving through 3d space, and since I could find no information on how to implement a 3d blendspace, I instead created 2 separate ones: One 2d with the x and y movement, and one 1d with the Z movement.

In the webm below, you can see how it “beautifully” addativily adds the root motions from both the 1d and 2d blendspaces causing the monster to move in all 6 directions. (up, down, turn left, turn right, forwards and backwards) depending on a supplied vector.

However, ingame, the 1d blendspace’s root motion isn’t applied! The other parts of the animation blend properly, i.e with the vector 0,0,1 I can see him brace the wings downwards as intended, but the root motion of that animation is ignored! Even though the root motion worked flawlessly in the preview!

The setup is really simple, and here’s some pictures of it:

Here we can see how the wings are bracing, but its still in the air instead of moving upwards as it did in the preview.

Here’s the super-simple animation BP of the state:

Here’s what I already checked and tried:

Correct state: There is only one state of the animation and that is the one in the preview.

Movement vector set correctly: Yes, even printed it out each frame when testing, its correctly at -1 or +1.

So anyone have any clue why it works as intended in the preview but not ingame? The first blendspace (the 2d one) has its root motion properly applied, so with the vector 1,0,1 it moves forwards, but not upwards, so the character seems properly set up.

Best regards, Adam.

sadly I can’t edit this post, nor remove it, but this is definitively a bug, otherwise the preview wouldn’t act differently than the ingame version. (yes both preview and default settings are the same). Hopefully this bug won’t be ignored like the other ones I asked about before here.

Duplicate question

Please see: