Application Loader ERROR 90503

Hello there!

I try to upload my IPA by Application Loader, but I’ve got this error every time

ERROR ITMS-90503: “Invalid Bundle. Apps that have ‘arm64’ in the list of UIRequiredDeviceCapabilities in Info.plist must only contain the arm64 slice.”

But in my plist is all correct:



Thanks in advance.

Hey There! I have the exact opposite. I have…

ERROR ITMS-90502: “Invalid Bundle. Apps that only contain the arm64 slice must also have ‘arm64’ in the list of UIRequiredDeviceCapabilities in Info.plist.”

I am only packaging the arm64 slice, but I can’t get the plist item to stay. How did you get the Info.plist to stay at arm64? Mine gets overwritten each time.

What version of UE4 are you using? In 4.17 the ability to select arm64 or armv7 in the project settings isn’t there anymore. I would assume because of iOS11.

I also assume that means that we are only packaging the arm64 slice now.

Are you changing the info.plist in Saved>StagedBuilds>iOS?

Hello, Onildera

I use 4.16
No, I didn’t change info

Ok. I think what I am telling you is correct…

If you aren’t using the source version of 4.16, you can’t do an arm64 only package. Someone please correct me if that isn’t the case.

Now in 4.17, it looks like you can only package arm64 for iOS.

I have a bug report in on the info.plist issue. I can add the arm64 to the plist manually, but it should be automatic be default now.

I am going to assume that the selections for arm7 and arm7s were removed in 4.17, but the code that creates the info.plist wasn’t updated to reflect the change.

Again, I am merely a user… Some of this may be wrong and I would welcome the correct info from anyone reading this.

Here’s a quick update…

Most of what I said above about 4.17.1 is true. However, it looks like the issue I was having is only occurring on migrated projects.