Application has been blocked from accessing Graphics Hardware

Hi, I am now at wits end, I have attached a screen shot and am busy uploading a video to show what is going on.

I have a gtx660ti (2Gb ddr5, i7, 16G RAM), Windows 8.1, all drivers (including Nvidia/Windows) are up to date.
I am running the latest stable code from Unreal (compiled from source 4.5.1) just after it released via github.

A few minutes into in-editor game or published game on PC, the game crashes, my temperature is 100% fine, it is 75 degrees.
my CPU temp and voltage monitors show no problems, graphics load is between 80 and 99 percent load.

I have done this test 4 times now each with a video to show what is happening, I can not continue my game like this, it is not possible. When I play games nothing crashes, so it must be something that is going on with Unreal.

It makes no difference with higher or lower settings, anti aliasing or not, nothing helps, with lower settings, it just runs a few minutes longer, but still crashes.

I will do any other tests you want/need, if you want me to play a game and post the results with monitoring I will.

The error used to be: Display Driver has stopped responding and has since recovered. That error has now been replaced with this one, I have also tried running the engine as an administrator, in the last 2 tests, and that makes no difference. Please can someone assist me, I will provide any info, logs or monitoring as required…

Each screenshot at the top from GPU-Z was at the time of the crash taken with nvidia shadowplay just before the crash

[link text][2]

Hey there, I also have a 660ti but have not had this issue so far.

75 degrees seems a bit hot to me, it looks like there is no problem in your video until it reaches a full 75. I have an ASUS 660ti and can not get it to go above 60 degrees in even the most demanding games. I noticed that your fan is only running at 60% though, try forcing the fan to run at 100% while testing and see if that makes any difference. Depending on your card manufacturer the cutoff point for max temperature could be set too low, you would need to open up your card’s configuration software to check this.

Also are you overclocking at all on the GPU? My base clock is 1046 (although I do overclock it to 1150). I did have problems in a couple of instances when overclocking beyond that point so it might be worth trying to reduce that down.

Looking through your log I found that it is throwing an exception when attempting to create a buffer on the D3D Device with error “DXGI_ERROR_DEVICE_REMOVED” which isn’t much help, but I see that your system has a built in “Intel(R) HD Graphics 4600” as well as your 660ti. It may be worth going into your bios and completely disabling that device. I did that on my to avoid any issues that may come up, it shouldn’t be using it as you don’t have a monitor hooked up, but could be worth trying.

Could you please post your DXDIAG and Editor logs as well, you can find details on how to obtain the logs from here. These will help us look into it further.

Thank you.

Hi, thank you for the info, yes the editor logs are present, I included the DxDiag now, The engine itself does not log anything during that time period, so I will include what I have,

And no, nothing is overclocked, my Asrock-Tuning indicates this is at standard, and I do not fiddle in the BIOS with overclocking, my machine is powerful enough to handle anything I throw at it, I do not need to try and squeeze more out of it…

My WER (Windows Error Report) is clean for today, the WER reportqueue is not being written to for this crash. As for the cooling the 75 degrees is perfectly fine, as long as it stays below 90 degrees there is nothing wrong with it, other games work fine with similar temperatures and load…

The logs also show the correct GPU driver is in use, so I doubt it has anything to do with on board graphics, it is not even being initialized by DirectX11.

link text

link text

Turns out it is Windows 8.1 Pro and DirectX 10+
I am also getting the same problem with games running DirectX 10.

I guess my days of developing games are over for now #sadface

I also have Win 8.1 Pro and have no issues with DX10…

I’m going to move this thread over to the bug reports / crashes section, see if some fresh eyes can see what I’m not.

Also just to see if it makes any difference, can you re-install the DirectX 2010 Redistributable package, in case it got corrupted somehow.

Yes, it is running in a game, I thought it was just with Unreal, but I have been playing games for 2 weeks straight now, and no issues, but I was playing Half Life 2 (Ep1 and 2) on full settings, which is DX9, and then I played Far Cry 2 on full settings, with DX10, about 5 minutes into the game, and I got exactly the same message. Yes I will try that right now, I don’t think this has anything to do with Unreal Engine.

It is something wrong with my system, I will run that right now and see if it helps, thank you for the feedback and options, so frustrating not to be able to dev. Brought out my xbox360 again to feel better. :wink:

Hi alwynd,

I’m sorry if you two have been over these options but I didn’t see it mentioned.

Do you have the most recent Windows system updates and the latest NVidia driver? Make sure you aren’t using the beta driver for your graphics card as they are sometimes unstable.

Your card supports DirectX 11, have you thought about updating? Even if you had UE4 working with DirectX 10, some features maybe limited (tessellation, high end shaders, etc.)

Hi, I do not run UE4 on DX10.
I have Win8.1 all drivers up to date, and my GTX660 ti has the latest Geforce drivers and experience. I am running UE4 on DX11, but it has nothing to do with UE… It is something on my system , I played FC3 last night and 5 minutes into the game it crashes with the same error. Guess it’s back to playing old games, and relaxing this holiday!

After more googling, I found a solution that finally worked, turns out my Gigabyte GTX 660TI comes standard overclocked out of the box, I installed Gigabyte OC guru, and set the base clock to -25Mz and have been playing almost non stop DX11 now since friday.

Before that, it couldn’t even get past the Far Cry 3 cut scene, never mind play any games, or do any development longer than a few measly minutes before rendering my maps either corrupted or broken as it crashed during an operation, thank god for experience and backups.

This is the longest this card has ever run full screen max settings DX11 since I bought it a year ago.

Thanx to all ho helped, but it turns out the drivers had nothing to do with it, nor the temperature, because I also clean re installed Windows 8 (includes an upgrade to win 8.1), disabled windows updates, and installed the Nvidia Driver 304.NN that came with the card, an it also did not work,

Took all but 5 minutes to establish that.

I have uninstalled Unreal now in the process as well, will get back to that when I have finished enjoying a card I thought was faulty for almost a year now…What a relief.

ha ha… I replaced my GPU with GTX 970.
My GTX 660TI gave up while playing far cry 3.

No problems ever since. Happy dev days! #happyface