Download

App Rejected due to TrueDepth API in a Non-Arkit project

Hi,
Like many that used 4.19 to package for Mobile iOS, we are getting a TrueDepth Reference in our app that Apple refuse during Review.
All the steps that people have done in the other threads to resolve the issue failed on our side. It has been 2 months now.

Apple Messages: Guideline 2.5.1 - Performance - Software Requirements
During review, we found that your app includes TrueDepth APIs. However, we were not able to locate any features in your app that use TrueDepth APIs.
Next Steps
If your app does not include any features that use TrueDepth APIs, please remove them from your app.

As your app uses the Unity ARKit plugin, it would be appropriate to update to the latest version, which includes a setting that allows you to exclude TrueDepth APIs.
If your app does include features that use TrueDepth APIs, please reply to this message in Resolution Center to provide information on how to locate them.

And later after 5 “fixes”. This app makes use of ARFaceTrackingConfiguration and ARFaceAnchor which are considered to be TrueDepth APIs. It would be appropriate to remove all TrueDepth features from this app before resubmission for review.

Steps Done: Note that ARKit was enabled back in 4.18 but was disabled for all other packagings since 4.19. All Packagings are done deleting Intermediates\Binaries and Full Rebuild to assure a clean Package.
We Updated to 4.21.2 which should have resolved the TrueDepth bug, It did not.
We tried Cleaning up the Apple ARkit and ARFace cpp but we are no experts (blueprint projects). One of the Epic Staff suggested we delete both ARKit and ARFace Support Plugins and recompile the source. However there still seem to be traces in the packaging.
Searching for “ARFace” in our last ipas with a Find and Replace program (GREP and FAR) returns nothing, maybe because it’s compiled. but our previous one did find “ARFace” traces.
We pretty much tried all in there https://answers.unrealengine.com/que…8388/view.html and some small other things found in other forums.
We have no idea what to do next, we might call Apple directly. Thanks, good day.

this was supposedly fixed in 4.24. however, my app was rejected with 4.23 and the 4.24 resubmit. unchecking the box for truedepth api didn’t seem to work. is there any method of using xcode or something to determine if a packaged ipa includes the truedepth api?

Same for me. Only way to solve seams is to remove AppleAR, but I uses AR function.
There is no way known to me to disable TrueDepth in the AR plugin. I am not using face recognition…only AR function.
Apple response: Either to remove TrueDepth (ARKit) or include TrueDepth functionality.
This means currently there are no Unreal AR apps accepted, as 4.24.3 does not fix the problem ?
What can be done, I wonder how others solve that issue for AR apps with unreal…

I had the same problem but I have just upgraded to 4.25 and this seems to resolve the problem and my AR Kit app (“Asteroid Recon”) has just been accepted by Apple Store.

(Note that I previously also had AR Face plugin enabled, but disabled it at the same time I upgraded to 4.25 so it could have potentially worked for me on 4.24.2 but from the comments above it looks as though the upgrade to 4.25 is what solved the problem).

Problem fixed with 4.25 and just in case, check your plug-in, that you have not enabled “AR KitFace Support”.
This enables TrueDepth in the build.