API level shows 28 in google play console even though in configuration and log shows it 31

I have signed and build an Android App bundle using API level 31. But when uploading to Google Play Console for internal testing, I get

Your app currently targets API level 28 and must target at least API level 30 to ensure that it is built on the latest APIs optimised for security and performance. Change your app's target API level to at least 30.

Looking at the logs I see that I’m using Level = 31. In fact I don’t even have 28 installed on my computer.

UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): Note: Some input files use or override a deprecated API.
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): Requires at least SDK API level 28, currently set to '31'
UATHelper: Packaging (Android (Multi:ASTC,DXT,ETC2)): Building Java with SDK API level 'android-31'

Anyone else had this issue? I saw another thread that explains to do Project Setting → Platform → Android → SDK API Level → Change to 30 (or above) But I have already done that.

Below are my settings.

Location of Android SDK: C:/Users/user/AppData/Local/Android/Sdk
Location of Android NDK: C:/Users/user/AppData/Local/Android/Sdk/ndk/23.0.7599858
SDK API Level: 31
NDK API Level: latest

I’m unable to put my game on Google Play. Appreciate the help in advance.

Dont worry its easy!
You added the version 31 to the Android SDK Settings, but I think you forgot to add it to the Android Settings too :)!

So what you have to do is …

(in my case its the version 30)

1 Like