APEX World Support

Hey UDN,

I have been looking over the Destruction Example levels and I can not get the World Support to work with any other meshes that I try. Is there some special setting that I need to add besides World Support? It’s really weird that it works on this one mesh but it will not work on any of the other meshes that are in that package when enabled. I have even tried importing a new mesh to fracture and also tried exporting a mesh from APEX labs and that still did not work. What am I missing here?


Sam Deiter

Here are links to the files. Could not attach them for some reason…



Hi Sam,

I think the problem is that you have the supportDepth set to 0. This means only the unfractured destructible is going to attach itself to the world. Once it’s fractured, the depth 0 chunk no longer exists and support is gone. Depth 0 support is only useful for extended structures, really. Please try setting the supportDepth to 1, or if you fracture it to a deeper depth and want more detailed support, you can set it higher. But the higher supportDepth is, the more costly the support graph calculations.

In case this doesn’t solve the issue, let me say that I was able to download the fbx file, but so far both IE and Chrome have identified the apx file as xml/text, and it’s treated differently. Instead of downloading, it’s loaded, and any attempt to save it hasn’t produced a usable file. Could you try uploading a .zip file instead, if you still need help with this?


Bryan Galdrikian


Here is a link to the .RAR as requested. I have have not had a chance to try what you suggested but I will try today when I get some time.


Let me know if the files I zipped up worked or not and if it does it probably means that I do not have it set up right. Thanks for the info and I will let you know if your suggestion helps out or not.



Okay it was exactly what you said that got it working. Setting the Support Depth from 0 to 1 made all of the peices breakoff and the peices that where stuck in the wall finaly stayed in place. Not sure how I missed that section when comparing the objects. But now it’s working so thanks for that.

Great, good to hear.